UtterAccess.com
We have detected that you are using an unsupported web browser. We recommend you to upgrade your web browser to get the most from UtterAccess forums.
Why should and how can I upgrade?
X   Site Message
(Message will auto close in 2 seconds)

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Datasheet Column Order, Office 2010    
 
   
mandrews
post Sep 10 2011, 09:38 AM
Post #1

UtterAccess Guru
Posts: 603



I have a split form with a datasheet at the bottom. I'm having troubles controlling the order of the columns in the datasheet. I used to just drag the columns to the order I wanted and save the form but it is not working
in Access 2010? I just want to set the order and have it always use that order.
Anyone know how to get around this issue?
Mark
Go to the top of the page
 
+
theDBguy
post Sep 10 2011, 10:25 AM
Post #2

Access Wiki and Forums Moderator
Posts: 57,850
From: SoCal, USA



Hi Mark,
haven't tried using a Split Form, so I apologize if I am pulling this one out of the air, but have you tried setting the order of the fields in the query you are using for your form?
Just my 2 cents...
Go to the top of the page
 
+
mandrews
post Sep 10 2011, 11:08 AM
Post #3

UtterAccess Guru
Posts: 603



I want to use mytable.* and I also don't think it uses the order of the fields in the query. datasheet functionality seems to have changed somewhat in 2010 vs 2007 (you now use the datasheet caption property for the heading and the order seems to be controlled by tab order maybe? (but not exactly or there is a bug sometimes)?
ark
Go to the top of the page
 
+
cpetermann
post Sep 10 2011, 11:23 AM
Post #4

UtterAccess Editor
Posts: 5,203
From: Omaha, NE USA



DB & Mark,
MFJI
Haven't used split forms, however in testing just now,
the split form does seem to use the order of the fields in the query.
When creating a splitform from a table, Access used the order of the table fields.
Tried going into table design & moving fields, the split form displayed the new order of fields.
Just my 2 cents...
Another 2 cents... tried move the order of the controls on the main form-- split form copied the order
Go to the top of the page
 
+
mandrews
post Sep 10 2011, 11:38 AM
Post #5

UtterAccess Guru
Posts: 603



My splitforms are not using the order of fields in the query and access has never done that (as far as I know).
think it is a columnorder property behind the scenes and when you paste fields the tab order of those fields controls the column order, however if multiple fields are pasted in and the form is saved many times some little glithes can be found (at least with NON SP1) which I currently have.
Most of the time I just change the tab order and the column will change position.
Okinda liked how access2007 used to do it where you could drag and drop things around to control the column order (as long as you saved the form).
Maybe this is a bug fixed in SP1?
My two cents,
Mark
Go to the top of the page
 
+
cpetermann
post Sep 10 2011, 11:50 AM
Post #6

UtterAccess Editor
Posts: 5,203
From: Omaha, NE USA



Try looking at your form in datasheet view,
drag your columns to the desired location,
save
Check form view.
My last 2 cents <
Go to the top of the page
 
+
mandrews
post Sep 10 2011, 06:37 PM
Post #7

UtterAccess Guru
Posts: 603



I tried toggling it from a split form to a datasheet, change the column ordering, saved the form. When I reload the form it reverts back to the original ordering.
ccess 2010 only NON SP1, Access 2007 always used to work the way you indicate.
My form is a split form, not just a datasheet so the final viewing is always as a split form with a header and datasheet at the bottom.
Looks like field order/tab order is what controls the ordering in 2010, I got around my original situation by cutting controls and pasting them back on the form.
They were originally in one large group (about 35 controls and about 5 of them were showing up fields 2 thru 6 (even through they were around 27 in the tab order)?
Mark
Go to the top of the page
 
+
cpetermann
post Sep 11 2011, 08:41 AM
Post #8

UtterAccess Editor
Posts: 5,203
From: Omaha, NE USA



design view
datasheet view
hide/move fields
Save
Form view
save
Layout view
hide/move datasheet fields Save
go Form view
Save again
Both worked for me
now I'm all outta cents <
Go to the top of the page
 
+
mandrews
post Sep 11 2011, 10:21 AM
Post #9

UtterAccess Guru
Posts: 603



what version of access 2010 do you have? SP1 or NON SP1?
Go to the top of the page
 
+
cpetermann
post Sep 11 2011, 05:45 PM
Post #10

UtterAccess Editor
Posts: 5,203
From: Omaha, NE USA



downloaded sp1 today.
orked for me again iconfused.gif
Is there anyway you could copy your db, remove sensitive data,
compact & repair, zip & attach?
Go to the top of the page
 
+
mandrews
post Sep 12 2011, 10:06 AM
Post #11

UtterAccess Guru
Posts: 603



I'll keep looking at it, it was a 2007 database before maybe that has something to do with it?
It least I know another person has it working normally (with the moving field columns around and saving).
Ocan't share the database (too much stuff in there),
Thanks for helping,
Mark
Go to the top of the page
 
+
cpetermann
post Sep 12 2011, 01:40 PM
Post #12

UtterAccess Editor
Posts: 5,203
From: Omaha, NE USA



Don't think so, the one i was testing had been 2007.
Good luck!
Go to the top of the page
 
+
syswizard
post Oct 6 2011, 10:34 PM
Post #13

UtterAccess Addict
Posts: 207
From: Media,PA



Well done Ms. Petermann. This problem was baffling at first....mainly because of the Freeze options in the Datasheet for each column.
The trick as you pointed out is to immediately SAVE the datasheet view, then SAVE the form.
Microsoft could have performed the SAVE when the datasheet view was exited....but they did not.
Go to the top of the page
 
+
mandrews
post Mar 13 2012, 07:28 PM
Post #14

UtterAccess Guru
Posts: 603



I hit this problem again and did some searching and all I came across was my last post here in UtterAccess, one of my team members gave me the answer:
asically it's an access 2010 bug:
One way around the bug:
If you open the list, move the columns into the correct order, right click a column heading and click unhide fields, then click close and save the form it should keep the order.
Just the normal way of moving columns around and saving the form does not always work (as it did in previous versions of access (like access 2007)).
I do not know if this bug always happens or if it is just with split forms (as opposed to regular datasheet view)?
Mark
Go to the top of the page
 
+
theDBguy
post Mar 13 2012, 09:39 PM
Post #15

Access Wiki and Forums Moderator
Posts: 57,850
From: SoCal, USA



Hi Mark,
Thanks for the tip! d=":thumbup:" border="0" alt="thumbup.gif" />
Go to the top of the page
 
+
ZizoBatal
post Mar 20 2012, 01:05 AM
Post #16

New Member
Posts: 1



I've been looking for the answer for the past two months . . . . . Finally !!!!
Thanks
Go to the top of the page
 
+
iawegian
post Jul 12 2012, 03:41 PM
Post #17

New Member
Posts: 1



Thanks to Mark, I got mine fixted too. Thanks so much!
hit this problem again and did some searching and all I came across was my last post here in UtterAccess, one of my team members gave me the answer:
Basically it's an access 2010 bug:
One way around the bug:
If you open the list, move the columns into the correct order, right click a column heading and click unhide fields, then click close and save the form it should keep the order.
Just the normal way of moving columns around and saving the form does not always work (as it did in previous versions of access (like access 2007)).
I do not know if this bug always happens or if it is just with split forms (as opposed to regular datasheet view)?
Mark
Go to the top of the page
 
+
treymarie
post Jul 19 2013, 10:46 AM
Post #18

UtterAccess Member
Posts: 47
From: Maryland



Wow. Thanks so much Mark! So glad I found this post. This has been driving me crazy for the last couple hours. It worked for me before in Access 2010 (not that long ago). The lastest update for Office 2010 must have created this bug. Quite an annoying bug. Microsoft needs to fix this!!
Go to the top of the page
 
+

Thank you for your support! Reply to this topicStart new topic

Jump To Forum:
 



RSS Search  ·  Go to Top  ·  Lo-Fi Version Time is now: 2nd September 2014 - 04:14 PM