UtterAccess.com
We have detected that you are using an unsupported web browser. We recommend you to upgrade your web browser to get the most from UtterAccess forums.
Why should and how can I upgrade?
X   Site Message
(Message will auto close in 2 seconds)

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Datasheet view of table hangs Access    
 
   
DSGarcia
post May 7 2009, 02:55 PM
Post #1

UtterAccess Addict
Posts: 240



I have a database with several tables created in Access 2003 (2002-2003 format) under Windows XP. I copied the database to a Vista machine running Access 2007. Access hangs up opening some of the tables (in datasheet mode) but not with most of the others. If I first open the table in design mode, right-click the title bar and select Datasheet View, it works fine. If I test validation rules, there are no errors. I tried a compact and repair, but get the same results. I created a query and was able to display the data. I deleted the data in the table from the query and now that empty table displays without hanging but I don't want to delete the data from the other tables just to make it work. The tables are not too particularly large. What gives and is there a way to fix this?
Thanks,
Dale
Go to the top of the page
 
+
Doug Steele
post May 12 2009, 11:43 AM
Post #2

UtterAccess VIP
Posts: 18,527
From: St. Catharines, ON (Canada)



Try creating a new database and importing the data from the existing one.
Go to the top of the page
 
+
DSGarcia
post May 12 2009, 07:49 PM
Post #3

UtterAccess Addict
Posts: 240



I made a copy of the database file and converted from 2002-2003 to 2007 format. It still hangs when opening in datasheet view (unless first going through design mode to display datasheet). I copied and pasted the table within Access with the same results. I deleted several fields and modified data in the tables with the same results. I sent it to someone else and they were able to open the tables in datasheet mode. I guess there must be a setting or something wrong with my version of Access.
Thanks,
Dale
Go to the top of the page
 
+
Doug Steele
post May 13 2009, 05:08 AM
Post #4

UtterAccess VIP
Posts: 18,527
From: St. Catharines, ON (Canada)



I did not suggest making a copy of the database file, nor using copy and paste.
Create a new database. Import the tables from the old database into the new one. You do this using the External Data tab on the ribbon.
Go to the top of the page
 
+
DSGarcia
post May 13 2009, 09:49 AM
Post #5

UtterAccess Addict
Posts: 240



Doug,
Sorry for the misunderstanding. I posted at the end of the day and was simply reporting what I had already done and planned on trying your suggestion this morning--which I did. Creating a new database and importing the tables from the old into the new still resulted in the same problem (Access stops responding when opening the tables unless opening datasheet from design mode).
Thanks,
Dale
Go to the top of the page
 
+
Doug Steele
post May 13 2009, 10:20 AM
Post #6

UtterAccess VIP
Posts: 18,527
From: St. Catharines, ON (Canada)



Sorry, I haven't heard of this problem before. Have you installed all updates?
Go to the top of the page
 
+
Bob_L
post May 13 2009, 10:25 AM
Post #7

Utterly Banned
Posts: 7,038



Can you post the database (provided there isn't sensitive info in it, of course) so we can see if the same behaviour happens on our computers?
Go to the top of the page
 
+
DSGarcia
post May 14 2009, 11:34 AM
Post #8

UtterAccess Addict
Posts: 240



I was finally able to download and install MS Office SP2 this morning. I still have the same problem with Access hanging when opening certain tables (in datasheet view).

Attached is a sample database and table.

Thanks,
Dale
Attached File(s)
Attached File  Hangs Access 2007.zip ( 13.23K ) Number of downloads: 9
 
Go to the top of the page
 
+
Bob_L
post May 14 2009, 11:43 AM
Post #9

Utterly Banned
Posts: 7,038



I'll have to check it from home tonight as I have 2007 at home and not at work. I did open the file just fine in 2003 and it loaded the datasheet almost immediately.
Go to the top of the page
 
+
jmcwk
post May 14 2009, 11:58 AM
Post #10

UtterAccess VIP
Posts: 12,463
From: Tacoma, WA.



Dale,
pened with no problem using 07 however just having the stand alone table in your attachment may not be enough to replicate the problem ????
Go to the top of the page
 
+
Bob_L
post May 14 2009, 12:02 PM
Post #11

Utterly Banned
Posts: 7,038



I was thinking the same, unless it occurs for them with just that table.
Go to the top of the page
 
+
DSGarcia
post May 14 2009, 01:59 PM
Post #12

UtterAccess Addict
Posts: 240



John, Bob, et al,
Even that small single table hangs Access 2007 (running under Vista) on my machine when I open it. I don't have problems on a different machine with Access 2003 (running XP). The funny thing is that others can open under Access 2007 and I can open datasheet view from design mode which makes it all the more confusing. Some tables I can open, some I cannot; I haven't seen any pattern though.

HAs you noticed, there are not many fields and the table is small. I deleted the indexes and non-numeric fields as well as the queries and VBA code. It's just something about my copy of Access or Vista but I haven't a clue yet as to why. I am using default settings for Vista and Access other than what came with the Access file.

Thanks,
Dale
Go to the top of the page
 
+
Bob_L
post May 14 2009, 03:32 PM
Post #13

Utterly Banned
Posts: 7,038



Just wanted you to know that I just opened it under Vista SP1, Access 2007 SP2 and it worked beautifully - no hang.
Go to the top of the page
 
+

Thank you for your support! Reply to this topicStart new topic

Jump To Forum:
 



RSS Search  ·  Go to Top  ·  Lo-Fi Version Time is now: 1st September 2014 - 11:16 PM