UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Enabling Macros For All Users On Startup, Office 2007    
 
   
Rob_Ross
post Jun 14 2012, 09:31 AM
Post #1

New Member
Posts: 5



Is there a way to enable the macros and VBA coding on startup for all users that log in? I have a database that will be accessed on line but would like to be able to set it up so the security warning at the beginning is taken care of automatically since the new database has the application frame hidden so they will not see the message.
Go to the top of the page
 
+
Peter46
post Jun 14 2012, 10:31 AM
Post #2

UtterAccess VIP
Posts: 7,489
From: Oadby Leics, UK



Personally I hope the answer to this is NO. Otherwise it would seem to make a mockery of the term 'security'.
Go to the top of the page
 
+
Rob_Ross
post Jun 14 2012, 01:06 PM
Post #3

New Member
Posts: 5



Let me word it another way, is there a way to get the enable macros message to come up in a pop up window since the Application window is hidden and noone will see it on the bar?
Go to the top of the page
 
+
pippie4trnc
post Jul 25 2012, 03:57 AM
Post #4

New Member
Posts: 2



Hi all,
I'm new to this forum so please be gentle!

Sorry to muscle in on this thread but I'm also having similar problems I think to this (along with many others which I hope you can help me resolve), although I suspect I'm a little less 'expert' than many of the people posting on here so please give it to me in simple terms!

When my database opens the user receives a Security Warning: 'Certain content in the database has been disabled'. Then they have to manually click on options and enable content. I wanted to get rid of this message appearing.

I tried changing the Trust Centre settings through Access Options to 'never show information about blocked content' but when I did that then every time I opened the database I received a message saying 'there was a problem sending the command to the program' and had to click on OK, although the the database was still opened! The database worked fine except when I needed to click on a button with a macro associated to it, then I got a message saying 'the Quit macro action cannot run with the specified 'options' argument either when in disabled mode or when called from an embedded macro.

Also interesting was that I noticed the min/max/close buttons were once again enabled on screen (I had disabled those previously to make sure the user was forced to click on my own button to 'quit') - could that have been something to do with the first message about 'there was a problem sending the command to the program'?

I switched the Trust Centre settings back but then have to go through the process of clicking on 'options' and 'enable content' again at startup and then having to wait for the database to close, compact and reopen. It is very frustrating.

Any help gratefully received.
Go to the top of the page
 
+
pippie4trnc
post Jul 25 2012, 07:12 AM
Post #5

New Member
Posts: 2



Just as a follow up - it's sorted!!

After a little more fiddling I've found that what I needed was in the Trust Centre Settings afterall - for anyone wondering - go to Trusted Locations in the menu on the left and then ensure you have the path required where the database is situated and tick allow sub locations too, just to be on the safe side.

That seemed to have done the trick with the security message I couldn't get rid of.

Now the only other thing to solve is getting rid of the min/max/close buttons again from the main window. Any help???
Go to the top of the page
 
+

Thank you for your support! Reply to this topicStart new topic

Jump To Forum:
 



RSS Search  ·  Go to Top  ·  Lo-Fi Version Time is now: 1st August 2014 - 02:46 AM

Tag cloud: