UtterAccess.com
We have detected that you are using an unsupported web browser. We recommend you to upgrade your web browser to get the most from UtterAccess forums.
Why should and how can I upgrade?
X   Site Message
(Message will auto close in 2 seconds)

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Missing Reference (owc11.dll) Access 2007, 2007    
 
   
KurtW
post Feb 24 2010, 12:07 PM
Post #1

UtterAccess Guru
Posts: 518
From: N. Colorado



Hi all. GREAT new look to the site, BTW!
One of my clients has started getting a "Missing reference" error while running an Access2003 Project I built when she opens it in 2007. It chokes on a call to Environ("Username"). Needless to say this has been working fine in 2003 and it still works fine on my 2007 instance.
Oknow that OWC11.dll is an office dll and my understanding is that Access 2007 shouldn't need to reference it. So what .dll does 2007 use to access environment variables?
Thanks.
Kurt
- Namaste -
Go to the top of the page
 
+
gemmathehusky
post Feb 26 2010, 12:52 PM
Post #2

UtterAccess VIP
Posts: 2,670
From: UK



if you develop in A2007, the reference will be upgraded to windows 12 versions - and wont automatically adjust for your user.
pen a module, and check for the references showing as missing - scroll down, and pick the windows 11 versions.
-------------
re-read this, and realise I misunderstood slightly - but still you ought to check the references.
Go to the top of the page
 
+
KurtW
post Feb 26 2010, 12:55 PM
Post #3

UtterAccess Guru
Posts: 518
From: N. Colorado



Yeah, last night I opened the user's version and found the MISSING reference toggled, so I unchecked it and that did it. I have no idea why the reference was there only on her machine but - at least it works now.
Thanks for your reply!
Namaste
Go to the top of the page
 
+

Thank you for your support! Reply to this topicStart new topic

Jump To Forum:
 



RSS Search  ·  Go to Top  ·  Lo-Fi Version Time is now: 24th October 2014 - 08:25 PM