Printable Version of Topic

Click here to view this topic in its original format

UtterAccess Forums _ UtterAccess.com News _ Bug(s) In Access 2016

Posted by: GroverParkGeorge Jun 15 2016, 05:02 PM

=============================
At this point, it looks like the bug has been fixed. I checked my Access 2016 (32 bit and 64 bit) installations on Win10. I see the full set of values for number datatypes.
July 1, 2016 @ 7:53PM PDT

Job well done, Access Team.
=============================


There is a bug in Access 2016. The MS Access team is aware of it, and is working on a fix for it. No ETA yet on when it will be available.

It involves the Datatype dropdown for Numbers.

Only the default datatype is available.

If you need to change or add number fields, the work around is to go to Options for Object Designers and change the Default Datatype for numbers to the one you need. It then becomes available in the dropdown in place of Long Integer.

There have been some reports that Wizards may also be broken. That, however, hasn't been widely confirmed.

ScottGem, Access MVP and UA VIP, is in contact with the Access development team and will let us know as soon as he gets any update.

http://www.UtterAccess.com/forum/index.php?s=&showtopic=2037473&view=findpost&p=2602127

UA Admin Team

 

Posted by: nvogel Jun 16 2016, 08:16 AM

QUOTE
There is a bug in Access 2016.

Seems like very positive news: that there is only 1 bug in Access 2016! smile.gif

Seriously, my point is a niggle aimed at Microsoft rather than you. For some of their products Microsoft publicly shares information about what bugs have been identified and whether / when they intend to fix them. As far as I know they don't usually do that for Access except in a few cases where they decide to publish a KB article. So as customers I don't think we have any reliable way of knowing what bugs exist and how many of them are being worked on by Microsoft support - unless you know better than I do of course.

Posted by: DougY Jun 21 2016, 04:49 PM

We heard back from the Access Dev team regarding this issue. The rendering issue on the field size drop-down with Access 2016 32 bit has been identified and investigated by the product team engineers. The product team is actively working on releasing a fix for this problem through the release channels as quickly as possible. We will post more as we hear about it from the team.

Posted by: DanielPineault Jun 24 2016, 06:01 AM

There are a number of simple workarounds that have been found. Please refer to: http://www.devhut.net/2016/06/17/field-size-option-not-working-in-access-2016/ for all the details.

Posted by: GroverParkGeorge Jul 2 2016, 08:11 AM

This is more than a niggle, IMO, nvogel. Microsoft could do a MUCH better job of proactively letting their loyal customers know what is going on. The current management team for Access has been doing a much better job, in fact, than previously was the case. For example, they started the UserVoice feedback for Access, and have already indicated theyhttps://access.uservoice.com/forums/319956-access-desktop/status/1667460requested there. It's progress in a tangible way for a change.

Still, you'd think it would be easier to get accurate information than it is sometimes.

Posted by: GroverParkGeorge Jul 2 2016, 09:33 AM

Just an FYI on Updates. These are the versions on my systems as of now.



Posted by: nvogel Jul 2 2016, 03:40 PM

When I click on your attachments I get an error message: "Sorry, but you do not have permission to use this feature".

Posted by: GroverParkGeorge Jul 4 2016, 11:24 AM

There is no attachment, really. It's just a couple of screenshots. Can't you see them at all?

Posted by: KeesB Jul 4 2016, 12:06 PM

L.S.

QUOTE
There is no attachment, really. It's just a couple of screenshots. Can't you see them at all?


Nope, just the standard blue attachment marker. And the the same error as nvogel.

Hold it. When in edit mode I see the pictures, but when clicked I get the error again.

Posted by: nvogel Jul 4 2016, 01:26 PM

No, I don't see the screenshots. I can see two attached files:

Attached File 2016_07_02_7_24_20.png ( 11.52K )Number of downloads: 2
Attached File 2016_07_02_7_30_35.png ( 9.87K )Number of downloads: 2

When I click on them I'm told I don't have permission to use this feature.

Posted by: GroverParkGeorge Jul 8 2016, 09:24 AM

Sorry about that.

The two version numbers are 10.0.6925.1022 for 32 bit and 10.0.4266.1003 for 64 bit.

These both have the Number data type display problem fixed.

Posted by: nvogel Jul 8 2016, 01:25 PM

The version I have is http://answers.microsoft.com/en-us/office/forum/office_insider-registration/announcing-insider-build-1607070xxxx-for-office/ae697df5-73d4-47d9-81a4-8ba21dabd0d9?auth=1 and I can confirm that the number dropdown bug is fixed.

Posted by: RiverKing Aug 30 2016, 12:08 PM

I STILL haven't received the update that corrects this problem and I have an Office 365 account. Haven't had time to hassle with Microsoft about that but I did take positive action just now --- I downloaded the table of Number types (Item 3 in DanielPineault's list at http://www.devhut.net/2016/06/17/field-size-option-not-working-in-access-2016/. That looks like it is going to work very nicely. Thanks much, Daniel.

Hopefully, this positive active will cause the update to arrive soon.

Posted by: RiverKing Oct 27 2016, 02:31 PM

STILL haven't received an update from Microsoft that corrects this issue in spite of having paid for an Office 365 subscription for two years now. I just suffered through a chat session and four phone calls over the course of 2+ hours with Microsoft support and accomplished nothing except to refuse to pay to debug their software. None of the people I spoke to, including Professional Support for Access (?), had any idea what I was talking about. The one thing I heard with which I can agree is that there should be an article number (i.e., a KBnnnnnnn ID) if the problem was reported, regardless of whether an update has been issued. Does anyone have that article/update number.

By the way, a search of answers.microsoft.com for "missing datatype" in Access returned one item describing a nearly identical issue in Access 2007!

Also by the way, Daniel Pineault's workaround works very nicely. Thanks again, Daniel,