UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> .display Email Before Sending Stuck In Outbox, Access 2016    
 
   
hhays
post Feb 13 2018, 07:37 AM
Post#1



Posts: 330
Joined: 19-July 12



I cannot believe my issue is giving me this much of a problem but I am completely baffled and have been stuck for 3 days... any help is so greatly appreciated... and needed...!

I have dozens of emails I send from Access through my Outlook Exchange account. They have worked perfectly for years but they recently stopped working...

Many of the emails I must .Display so I can add additional information to the body before I send it... When I .Display the message and then send it by clicking the Send button, it gets stuck in Outlook's Outbox and it won't go out until I Open Outlook and perform a Send/Receive.

I have noticed quite a few other users have experienced this same issue but there is no clear solution and nothing I have tried has worked...

I have uninstalled Office, Ran Office Repair tools, I have made sure all my lib references are set in both Outlook and Access, I have Ran Repair tools to make sure the correct account and license is connected, I have Unchecked Cached Exchange Mode, I have Checked Send Immediately when Connected, I have tried late binding, early binding, I disabled Ad-Ins, I removed Ad-Ins, I have stripped my email code down to a bare bones basic email (the code is below) and it still gets stuck...!!!

I am sure it is such a simple little tweek but I just cannot figure this out... It is probably going to kill me to find out how to fix this issue and I should've reached out two days ago but I'm a little stubborn and kept thinking the answer is just around the corner...

I really need somebody to please enlighten me as to what the [censored] is going on...!!????!!?!??!

CODE
Private Sub Simplebtn_Click()

Dim oApp As Outlook.Application
Dim oMail As MailItem

    Set oApp = CreateObject("Outlook.application")
    Set oMail = oApp.CreateItem(olMailItem)

        With oMail
         .Body = "Body of the email"
         .Subject = "Simple Email"
         .To = "info@myemailaddress.com"
         .Display
        End With

Set oMail = Nothing
Set oApp = Nothing

End Sub
Go to the top of the page
 
ranman256
post Feb 13 2018, 08:52 AM
Post#2



Posts: 867
Joined: 25-April 14



in DISPLAY mode, it is waiting for the person to do something...send it or save it.

you can:
CODE
    .Display false
    .Save


this saves it to the DRAFT and should keep moving.
Go to the top of the page
 
hhays
post Feb 13 2018, 09:31 AM
Post#3



Posts: 330
Joined: 19-July 12



Thank you for your reply...

I need to Display the message so I can edit it... After I edit it I click the send button on the message window and "Sends it" and it closes the message window but it just gets stuck in the outbox...

If I Remove .Display and put .Send it will send the message but I have to be able to edit the message content and view the final message before sending...
Go to the top of the page
 
hhays
post Feb 16 2018, 11:53 AM
Post#4



Posts: 330
Joined: 19-July 12



Does anyone have any suggestions...? I am still working on a solution and still haven't gotten any closer...

One thing I have noticed is that when I send mail from outlook directly it also is going to the outbox for a few seconds...

I know this is more of an outlook question but does anyone know if this is standard for outlook...? Do all messages sent from outlook go to the outbox first...?



**********************EDIT********************

Another thing I just noticed... If I send an email from Access and first I .Display the email then click send.... and before I open outlook I send another email from Access where I do not .Display it but just .Send it... Then both the emails are sent...
This post has been edited by hhays: Feb 16 2018, 12:24 PM
Go to the top of the page
 


Custom Search
RSSSearch   Top   Lo-Fi    17th July 2018 - 02:40 AM