UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> New Sharepoint Column Not Acting Correctly When Linked In Access As A Table, SharePoint 2013    
 
   
blueman2
post Aug 14 2018, 05:03 PM
Post#1



Posts: 169
Joined: 15-November 14



I've had this database running for years on sharepoint as a back end with front end access on various computers. I have added a column to an "Order Details" list in sharepoint. I've done this before when I needed a new field in the corresponding table so that I can use it in forms, queries, etc. The new field is called ShipOrigin. It will store a numeric value which will represent a text entry in my table called tblShipOrigin. Here is an image showing the column entry. I've done this just as I have in the past:

Attached File  column_setting.jpg ( 113.31K )Number of downloads: 2
]


When looking at the list on sharepoint I see the column and no entries for that column which would be correct

Attached File  Image_28.jpg ( 180.86K )Number of downloads: 1


I went back to Access, deleted the Order Details table (link to sharepoint) and then brought it back into access so it would link showing the new field.
However, what I See is 2 new fields in design view for the Order Details table instead of the one new one that I added on sharepoint.

Attached File  order_detail_table_design_view.jpg ( 57.56K )Number of downloads: 1


AND, when I look at the table view for Order Details there is only one column but it is filled with nonsense numbers

Attached File  order_detail_table_view.jpg ( 203.52K )Number of downloads: 2


n case this is of importance, here;s the properties for both ShipOrigin fields/columns that ended up in the linked access table.

Attached File  Image_32.jpg ( 104.76K )Number of downloads: 0
Attached File  Image_31.jpg ( 107.02K )Number of downloads: 0



I am at a loss to figure out what's going on and how to correct it. If anyone can help, I'd greatly appreciate it.


Running Access 2013
This post has been edited by blueman2: Aug 14 2018, 05:05 PM
Attached File(s)
Attached File  Image_27.jpg ( 166.32K )Number of downloads: 0
 
Go to the top of the page
 
GroverParkGeorge
post Aug 16 2018, 08:54 AM
Post#2


UA Admin
Posts: 33,494
Joined: 20-June 02
From: Newcastle, WA


Unfortunately, troubleshooting from afar is hard.

It sounds like something went wrong when you added that new field to the SharePoint list.

What I would do at this point is

a) make a backup copy of the list
b) in the original list, rename the bad field by prefixing it with Z_ or something that suits your preferences.
c) add another new field defined as you expect it to be used.
d) relink the list in Access as before.
e) if the new field behaves properly, then you can delete the old Z_ field that somehow went off the tracks.


--------------------
My Real Name Is George. Grover Park Consulting is where I do business.
How to Ask a Good Question
Beginning SQL Server
Visit My Blog on Facebook
Go to the top of the page
 
blueman2
post Aug 16 2018, 10:32 AM
Post#3



Posts: 169
Joined: 15-November 14



Thanks for your reply. I did find a fix in another thread somewhere but I'm not sure what the ramifications are. I went into options and selected "Never" for using the cache format.

Attached File  Image_7.jpg ( 34.5K )Number of downloads: 1


Then I closed and re-opened the database and the field for "ship origin" looked as it should. But in addition, another column/field was made called "modified" into which all the entries that were auto-populating into the "ship origin" field were moved to. And from what I can tell, these dates were just about the date that each of these records were created.

Attached File  fixed.jpg ( 284.26K )Number of downloads: 0


So now, my question is: what is the consequence of setting this to "Never"?

Is there a better option?

And does this help us figure out where the problem was?

Thanks
Go to the top of the page
 


Custom Search
RSSSearch   Top   Lo-Fi    21st September 2018 - 10:52 AM