UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Access Says, "there Are No Records To Display", But..., Access 2007    
 
   
ztatzau
post Jun 1 2017, 05:22 PM
Post#1



Posts: 311
Joined: 4-April 07



I distribute a number of Access runtime applications (accdb>accde>accdr) created in Access 2007. The code is pretty much bullet proof with many systems running on systems from Windows XP through Windows 10 with no problems. I've been using SSE setup 7.8 for distribution and setup which tests for MS A2K7 or later and installs the A2K7RT if no access is found. Everything has been working great! Until now, of course.

This particular system prints a number of reports, including name badges and other output on 4x6 index cards. I've been using Bernie's (Pere de Chipstick) custom printer select routines to set paper size, orientation, and margin settings. That's been working great too!

I just sent out a new system for a show NEXT WEEK! The system was fully tested on Windows XP, 7, and 8. I've never tested any of my software on Windows 10 as I've, until now resisted the new (intrusive) operating system, but all reports from clients everything installs and runs great on Windows 10. On this new system, on Windows 10, when selecting a button to print a name badge or any other 4x6 output, Microsoft access reports, "There are no records to display." This is not my error trapping which would be titled with the name of MyApp, but the Access (database engine?) that's reporting this error in a message box. The thing is there are records to display and the one they're trying to print is presently displayed on the form containing the Print Name Badge button!

I reran the same installation package on two or three machines here and when everything ran fine I bit the bullet and went out and bought a Windows 10 machine to see if there was indeed a Windows 10 problem. So I run the install on my new Windows 10 machine and, as expected, everything runs and prints just fine. I cannot reproduce the problem.

Unfortunately the client is halfway across the country. Right now I have them, making sure of their Windows 10 default printer setup settings, swapping back up files of the FE and BE just in case there was some corruption in the install package(s). And then if that doesn't help, remove and reinstall the application with fingers crossed.

Any other suggestions? Or any ideas why Access says, "There are no records to display!", when there is?
I could use some help with this one!

ZT
Go to the top of the page
 
GroverParkGeorge
post Jun 1 2017, 07:06 PM
Post#2


UA Admin
Posts: 31,197
Joined: 20-June 02
From: Newcastle, WA


The report must not be seeing the records.

Does the remote location have the same data as you have? Is this a split database? If so, did you send them both the BE and FE and did they relink the BE in its new location?

--------------------
Go to the top of the page
 
ztatzau
post Jun 2 2017, 11:03 AM
Post#3



Posts: 311
Joined: 4-April 07



Thanks for your reply George! Yes database is split. FE and BE reside together in the application's folder... C:\MyApp. The exact same installation/setup program and files used in all my testing were also used by the client.

And so, based on the following info received from my client this morning, I am somewhat relieved that this problem is likely not with my program at all but rather a wireless printer / setup / connection issue of some sort. From the client...
=========================
We have worked back and forth with different things and have came to the conclusion that it is not communicating with our new printer when it comes to the badges and cards. It does print the reports because we have printed we setup the printer in the program. Have check about the windows automatically deciding computer and it is off that is if we looked in the right place. When we use our printer on the program we can print the badges and cards.


Also both printers we are using are wireless printers. We can send all badges cards and reports to our wireless printer and they all print but when we send the badges and cards to the new wireless printer We can't even get the print preview screen to come up. All the reports will print but no cards. Finally I can say also that if we connect directly in each computer with the cord for the new printer it was printing everything. If you have any ideas on what to look for please let me know.

=========================
At this point my questions for you all here on the Runtime Forum, are...

Does anyone have any ideas on what may be wrong with the client's wireless printer setup / settings? Or what further advice I can provide to them?

And stranger yet to me is, when the name badges and cards cannot be successfully printed (for whatever reason) to a particular printer, how is it that Microsoft Access jumps in, cancels the print preview, and advises, "There are no records to display!"?
Attached File  NoRecordsToDisplay.jpg ( 60.21K )Number of downloads: 0

Thanks again to anyone for help on this one! ZT
Go to the top of the page
 


Custom Search
RSSSearch   Top   Lo-Fi    12th December 2017 - 04:28 PM