X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
   Reply to this topicStart new topic
> Adding Record To Back-end On Network Causing Err 3027, Access 2016    
post Jun 17 2017, 10:08 AM

Posts: 9
Joined: 8-December 11

This was not an issue prior to Office 365. We have 4 front end DB's posting to a table on one backend DB on a network when the user clicks OK on a form. That table has one autonumber field which is the primary index. Occasionally (keyword occasionally), when a user clicks OK they get a 3027 error. This can happen when there is only one user posting (ie everyone else is gone and their front end DBs are closed). Trapping shows the error is occuring at AddNew. The front-ends are used everyday. I cannot duplicate but will say it does seem to be more prevalent when users complain of slowness (which is another gripe of Office365)

Set MyRS = CurrentDb.OpenRecordset("MyDB", dbOpenDynaset, dbAppendOnly)

I have tried different solutions over the past few months but nothing has stopped this error from popping up occasionally. Any advice or experience is appreciated.
Go to the top of the page
post Jun 17 2017, 10:16 AM

Access Wiki and Forums Moderator
Posts: 74,667
Joined: 19-June 07
From: SunnySandyEggo


Welcome to UtterAccess!

Pardon me but what is error 3027? Also, can you briefly describe what you have tried? Just want to make sure we don't tell you to do the same things.
Go to the top of the page
post Jun 17 2017, 10:44 AM

UA Admin
Posts: 34,663
Joined: 20-June 02
From: Newcastle, WA

Apparently, this error means that the database file is read-only.

Why would that be the case for some users? And is this intermittent for ALL users? Or does it always occur for SOME users, but not others?
Go to the top of the page
post Jun 17 2017, 09:53 PM

Posts: 9
Joined: 8-December 11

As GroverParkGeorge posted, it seems to indicate the database is in a read-only state. Have looked at threads about recordsets/query not being updateable but my recordset is a linked table, not a query. Yes it happens to all 4 users at one time or another. Sometimes it is almost as if the only user posting data is somehow putting the backend into a 'read-only' state. Right now when the error occurs (which always happens at MyRS.AddNew) the error handler performs a MyRS.close then waits a few seconds then 'Resume's back to 'Set MyRS = CurrentDb.OpenRecordset("MyDB", dbOpenDynaset, dbAppendOnly)'. It will try 5 times before producing an error message telling the user to notify me. To my knowledge, once the error handler is invoked it always tries 5 times (ie no one has ever said it tried 3 times then finally saved without error). FYI - In the openrecordset call, 'MyDB' is a linked table with a Primary Index having one key field which is an AutoNumber field.

Any ideas for a better error-handler? Something that could removed/change the 'read-only' state of the back-end.

So frustrating when it used to work fine before 365. Company is pushing to move away from Access and these types of issues along with slowness are not helping. Sorry to vent.
Go to the top of the page

Custom Search

RSSSearch   Top   Lo-Fi    19th March 2019 - 01:18 AM