UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Access 2016 Error 80040e37 When Accessing Linked Tables Programmatically (VBA), Access 2016    
 
   
kburton
post Nov 22 2017, 03:51 PM
Post#1



Posts: 1
Joined: 8-November 17



I have been developing an Access application utilizing two desktops (Win 7 Enterprise 64bit with Access 2013 64bit and Win 7 Home 64bit with Access 2016 Pro 64bit) and a laptop (Win 10 Home 64bit with Access 2016 Pro 64bit). I had prior to my encountering the problem I'm about to describe Office 2007 Enterprise 32bit on both "Home" computers. The databases that I'm developing incorporate multiple databases with multiple tables, with each database accessing the tables of the other "external" databases as "Linked" tables. Everything has been going fine (manually as well as programmatically opening the tables, whether linked or direct - i.e., not externalized).

And then I installed Office Pro 2016 64bit on both "Home" computers. Now I cannot, for the life of me, programmatically open ANY newly created linked table, getting the infamous 80040e37 error. I can access ALL the tables (old or new, linked or not) manually - i.e., double clicking on the table from within the database. And I can programmatically access ALL the tables (by all computers) which had been linked prior to the install of Office Pro 2016, but not so with ANY table linked after the install (from any of the computers). What's even more baffling is that I'm getting the 80040e37 for new tables linked and accessed by the vintage Access 2013, without Access 2016 being involved at all. I've even created two new databases with Access 2013, manually set up a link, and without Access 2016 being involved at all, still get the same error with Access 2013.

I've tried not only linking the tables manually, but programmatically as well, with the same results. I have reinstalled Office Pro 2016 to no avail. I've searched the Internet for clues and/or others experiencing the same problem, but to no avail. (And I cannot believe nobody else has stumbled on this same issue.)
Go to the top of the page
 
GroverParkGeorge
post Nov 23 2017, 06:59 AM
Post#2


UA Admin
Posts: 31,239
Joined: 20-June 02
From: Newcastle, WA


Welcome to UtterAccess.

First, what is the error message that goes along with the error? That looks more like a non-Access error to me, but I don't recognize it (which isn't odd given that I don't even try to memorize all of the possible error numbers).

This also appears to be a factor of installing and using the 64 bit version of Access since that's when the problem appeared. Most problems we see here arise from API calls when an accdb created under 32 bit Access are then used in a 64 bit installation (version, 2013 or 2016, is not the primary factor here). That leads to the question, what APIs do you use, if any?

That said, since this error appears whether you try to link tables manually or in VBA, it's not really clear why the problem exists unless it is directly the result of such a problem with APIs.

Finally, just to be clear, your problem is trying to use linked tables in VBA, but not when they are bound directly to forms or reports? Is that the case?

--------------------
Go to the top of the page
 


Custom Search
RSSSearch   Top   Lo-Fi    17th December 2017 - 04:53 AM