UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
> Table Not Updating, Access 2010    
 
   
SemiAuto40
post Dec 7 2017, 04:17 PM
Post#1



Posts: 459
Joined: 3-April 12
From: L.A. (lower Alabama)


I am having the most aggravating time calling my LogChange in its own module from another form after changes made pullhair.gif
With this code I get a runtime error 3134. I have tried with some success to open a recordset and .addnew - but even that won't work every time.
Anyone? Please?

CODE
Public Sub LogChange(TimeStamp As Date, Old_Classification_ID As String, OldSequential As String, OldRev As Integer, New_Classification_ID As String, NewSequential As String, NewRev As Integer, Activity As String)
        
  Dim strSQL as string

       strSQL = "INSERT INTO tbl_ChangeLog (TimeStamp, UserName, Old_Classification_ID, OldSequential, OldRev, New_Classification_ID, NewSequential, NewRev, Activity ) " & _
                    "VALUES (" & "#" & TimeStamp & "#," & "'" & MyUserName & "'," & "'" & Old_Classification_ID & "'," & "'" & OldSequential & "'," & OldRev & "," & _
                    "'" & New_Classification_ID & "'," & "'" & NewSequential & "'," & NewRev & "," & "'" & Activity & "'" & ");"

            DoCmd.SetWarnings False
            DoCmd.RunSQL strSQL
            DoCmd.SetWarnings True
Go to the top of the page
 

Posts in this topic



Custom Search
RSSSearch   Top   Lo-Fi    18th December 2017 - 09:46 AM