UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Font Changes Automatically In Report And Form, Access 2007    
 
   
hafsarabic
post Dec 21 2017, 12:29 PM
Post#1



Posts: 130
Joined: 28-April 15



Dear sir

I use a specific unicode font in my forms and reports. But sometimes it permanently changed to windows default font automatically. How to solve this problem?

Regards,
Abu Hafsa.
Go to the top of the page
 
GroverParkGeorge
post Dec 21 2017, 01:05 PM
Post#2


UA Admin
Posts: 31,598
Joined: 20-June 02
From: Newcastle, WA


"... sometimes it permanently changed ..."

WHEN does that happen? Does it happen to ALL users for ALL forms and reports?

Is this a font that all of your users have installed on their computers?

--------------------
Go to the top of the page
 
hafsarabic
post Dec 21 2017, 09:11 PM
Post#3



Posts: 130
Joined: 28-April 15



It has no specific time. But it seems to me, it happens if I create the database using Access 2007. It does not happen to all users and also not in every forms and reports. The font is installed on all users computer.
Go to the top of the page
 
JonSmith
post Dec 22 2017, 06:34 AM
Post#4



Posts: 3,227
Joined: 19-October 10



Its permanently changed? As in you can not change the font again? That doesn't make any sense.
Go to the top of the page
 
GroverParkGeorge
post Dec 22 2017, 06:53 AM
Post#5


UA Admin
Posts: 31,598
Joined: 20-June 02
From: Newcastle, WA


How about the default printers? Are they all the same? Do the users all print to a single network printer or to one of their own? Is this font supported on all printers?

--------------------
Go to the top of the page
 
hafsarabic
post Dec 22 2017, 12:16 PM
Post#6



Posts: 130
Joined: 28-April 15



JonSmith, As far as I know there is know way to change textbox font in ACCDE file.

This post has been edited by hafsarabic: Dec 22 2017, 12:17 PM
Go to the top of the page
 
GroverParkGeorge
post Dec 22 2017, 01:36 PM
Post#7


UA Admin
Posts: 31,598
Joined: 20-June 02
From: Newcastle, WA


So, you're distributing this as an accde, then?

That DOES make a difference.

I'm now more convinced that your user's problem is that the font you designate is not available on that user's computer, or in the printer set up as the default printer for that user.

--------------------
Go to the top of the page
 
hafsarabic
post Dec 22 2017, 02:21 PM
Post#8



Posts: 130
Joined: 28-April 15



QUOTE
I'm now more convinced that your user's problem is that the font you designate is not available on that user's computer, or in the printer set up as the default printer for that user.


My designated font is installed on the user's PC. There are six reports on that database. All reports working fine except one.

This post has been edited by hafsarabic: Dec 22 2017, 02:22 PM
Go to the top of the page
 
GroverParkGeorge
post Dec 22 2017, 07:03 PM
Post#9


UA Admin
Posts: 31,598
Joined: 20-June 02
From: Newcastle, WA


Ah, another bit of crucial detail....

One report out of several displays this problem, and only on one user's computer.

Let's focus on that one report.

Does it also use the default printer? Do the other reports that do work use the same default printer? If so, it's possible that one report is bad in that one copy of the database.

Can you correct the problem by replacing that report in the user's copy of the FE?

--------------------
Go to the top of the page
 
JonSmith
post Dec 23 2017, 06:22 AM
Post#10



Posts: 3,227
Joined: 19-October 10



You are correct about accde but it was totally unreasonable for you to assume any of us would know thats what you were talking about.
You are giving breadcrumbs of info and are really lucky there are some patient people here asking lots of questions without always getting answers in order to fill in the gaps.

You need to help us to help you. Take the time to write a proper message with the situation with details such as its on a front end compiled file, its distributed to x users and only some have issue and its only on a particular form etc etc. Give us the whole picture and it might make sense.
Go to the top of the page
 


Custom Search
RSSSearch   Top   Lo-Fi    19th January 2018 - 02:41 AM