Full Version: Mscomctl.ocx Missing
UtterAccess Forums > Microsoft® Access > Access Forms
johnp
We have had an Access DB running in our facility for 3 years, every so often, i update the front end and deploy it to a few machines. Updates have always gone well, except this time, i have a machine that kept getting a datediff error upon loading the main form. We deploy a .accdr on the computers, to see what could be wrong, i ran the .accdb version of the db and checked references, on this user's pc, she is missing the library for MS common controls. This is odd, since this user has been running variations of this app for 3 years now. Anyway, i can see where the missing .ocx file is located with the browse button from the references screen, if i click on the file and select ok, it does not seem to put the library into the list of references, instead, it still shows 'missing'.


Is there a trick to pointing to the reference library on this person's pc? Or do I need to install something? Or maybe the user needs admin rights to the folder in order for it to be installed?

Also, I do not understand why suddenly this is happening to the one pc, nothing was added or removed from it lately. Any tricks on installing the library or is it as simple as pointing to it and clicking ok?
Garfieldm842
If you can find the "working" file on your PC then you may be able to move that file onto the PC that is not working into the same folder location.

Of course a re-install of the program that creates the file may also work. But, we have moved a working referenced file from 1 PC to our Network before. Then once on the network we could access it for a users PC and copy it down to where it was needed.

Good luck!
RuralGuy
It could also be a *bogus* MISSING Reference. Try unchecking the reference and recompile. See if your issue goes away.
johnp
Thanks,
It did indicate the file was in the windows\system32 folder but it did not seem to remove the missing message when i ok'd it. So not sure if it was bogus or not, just to see, i removed the reference library from my .accdb, compiled it, recreated an .accdr file and gave that to the user. It worked fine.
Garfieldm842
Great!
This is a "lo-fi" version of UA. To view the full version with more information, formatting and images, please click here.