Full Version: Combobox Bound To Yes/no Field
UtterAccess Forums > Microsoft® Access > Access Forms
doctor9
I'm sure this is something simple, but I can't see what I'm doing wrong.

I have a Yes/No field in my table named "boolRepresentative". On the form I want a combobox bound to that field instead of a checkbox, and the user selects either "Representative" or "Unrepresentative". Here's what I've tried:

Row Source: True;"Representative";False;"Unrepresentative"
Row Source Type: Value List
Bound Column: 1
Column Count: 2
Column Widths: 0";1"

In my mind this should work, but when I select either choice, it vanishes when I release the combobox arrow control. What am I doing wrong?

Dennis
Alan_G
Hi

Try changing the rowsource to

Row Source: -1;"Representative";0;"Unrepresentative"
doctor9
Alan,

Well... that worked. The weird bit is that I started out with the value list True;False and that seemed to work, so I just inserted the text after each value. Apparently Access didn't like that. It didn't try to insert quotation marks around the words, so it's not that they were being treated as strings. Weird.

Thanks!

Dennis
This is a "lo-fi" version of UA. To view the full version with more information, formatting and images, please click here.