Full Version: Database Corrupted!
UtterAccess Forums > Microsoft® Access > Access Forms
spennyc
Please help!
returned this morning after a week's holiday to be advised of a problem on 'one' record - it would appear that parent/child relationship lost on a subform (or underlying one to many record - record 'lost' in many table).
In attempting to correct access through up a 'not recognizable format' error when trying to open offending table.
Tried compact and repair on back end - when opening access informs me that database is not recognizable format and requires repairing - when I hit 'repair' it tells me password (which is definitely correct) is not recognized.
Have gone to latest back up available and this opens ok - did compact and repair (which worked ok although took a long time) - all appears ok but access has included a new table - MSysCompactError - with four fields and one record as below:-
ErrorCode - "-1017"
ErrorDescription - "Could not find field 'Description'"
ErrorRecid - two boxes (looks like when you open an excel file in word)
ErrorTable - ApplicationDetails
This table is the one that caused the probs originally.
Please help me to correct - all users are currently out of database and are 'twiddling thumbs' until fixed.
I hope someone can help......
Thanks!
JayNoelOlimpo
Suggestion:
Take a new mdb and Import all Tables from the Corrupted database ...
Then do the repair and Compact ...
spennyc
Hi
Thanks for post...
Will this keep the relationships or do I have to reconstruct them all again.
Cheers!
JayNoelOlimpo
It will keep ....
lso when you import click on the Options and Check menus and Toolbars to include your customized menus and toolbars ...
spennyc
Hi
When I try to import it comes up with the same message:-
The database "databasename.mdb" needs to be repaired or isn't a database file.
You or another user may have unexpectedly quit Microsoft Access while a Microsoft Access database was open.
Do you want Microsoft Access to attempt to repair the database?
Yes/No
If I click Yes, it says 'Not a valid password' with just an ok box - when I click ok it says ' the database...... cannot be repaired or isn't a database file.
Any ideas???
kuifjexx
Did you used security?
Maybe this can help
=> How to troubleshoot and to repair a damaged Access 2002 or later database
=> Corrupt Microsoft Access MDBs FAQ
Greetz from Belgium compute.gif
Luc aka Kuifjexx
spennyc
Thanks, Luc
ill take a look at - have temporarily 'solved' by using the compacted/repaired back up copy, but the presence of the MSysCompactError table concerns me..........
Thanks again for your post.
Regards
kuifjexx
Keep us informed ... hope you can solve the problem ...
heck the links, if still questions do not hesitate to ask
Greetz from Belgium compute.gif
Luc aka Kuifjexx
spennyc
Luc
Seems now to be working ok on back up copy that was compacted/repaired - however do you (or anyone else) know about this MSysCompactError table - there is one record in the table, which I presume (hope!!!) means there was an error in just one record.
Can anyone supply any info on this??
Whilst the db appears to be working 'normally' now, I am concerned about any repetition.
Thanks
kuifjexx
Not find any significant information concerning this error
est thing do is on regular bases make a backup & do a compact and repair.
BTW :
1/ do you have the latest updates of your Access Application
2/ is your application split?
Greetz from Belgium compute.gif
Luc aka Kuifjexx
spennyc
Hi again Luc
ortunately db is backed up every 30 mins, compact/repair done daily.
1. Yes all latest sp's applied
2. Yes, separate f/e on each machine linked to common backend on network, using workgroup file (shortcut on each desktop)
Thanks for your help - fingers crossed for no repetition!!
Best Regards
kuifjexx
Glad to hear that everything is smoothly
shall cross my fingers also wink.gif
Good Luck
Greetz from Belgium compute.gif
Luc aka Kuifjexx
DaveHall
Read this page http://www.fdrlab.com/tips.html
Have Hall,
FDRLab Data Recovery Centre Consultant
This is a "lo-fi" version of UA. To view the full version with more information, formatting and images, please click here.