UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Run Time Error 2293 - Can't Send This Email Message, Any Version    
 
   
amaklop
post Aug 19 2019, 02:02 PM
Post#1



Posts: 26
Joined: 23-September 18



Hi

I have Microsoft Access 2019. I have a database that has been using the DoCmd.SendObject command without a problem. Suddenly today I'm getting a run time error 2293 which tells me that Microsoft Access can't send this email message. I'm using Mailbird as my email client. I have send a test message from Mailbird and it sent fine so my email client is working.

I have tried mailing 2 different reports and both are giving me the same error. I can open the report and view it in PDF so the report itself does not have any issues.

This is my code :

DoCmd.SendObject acSendReport, "R_CombinedInvoicList", acFormatPDF, EmailAddress, CCEmailAddress, , "InvoiceNo # " & InvoiceNo

The person in the office isn't sure whether an update on Office or Mailbird was done recently.

I have recompiled my db and run a Compact & Repair. I closed and restarted both Mailbird and MS Access, still the error remains.

Any suggestions? I'm not sure what to try anymore frown.gif
Go to the top of the page
 
amaklop
post Aug 19 2019, 02:05 PM
Post#2



Posts: 26
Joined: 23-September 18



Not sure if this means anything but I closed Mailbird and opened Outlook. Thought if the issue was Mailbird it will be resolved if I used Outlook but I'm still getting the same error message.
Go to the top of the page
 
theDBguy
post Aug 19 2019, 02:05 PM
Post#3


Access Wiki and Forums Moderator
Posts: 76,380
Joined: 19-June 07
From: SunnySandyEggo


Hi. Are you able to test your db/code using a different computer? When code suddenly stop working without any changes, we tend to look at changes that may have happened to the environment or computer system.

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
amaklop
post Aug 19 2019, 03:21 PM
Post#4



Posts: 26
Joined: 23-September 18



Hi

I have run the db on another computer and it sends the mail with no errors.
Go to the top of the page
 
theDBguy
post Aug 19 2019, 03:24 PM
Post#5


Access Wiki and Forums Moderator
Posts: 76,380
Joined: 19-June 07
From: SunnySandyEggo


Now, compare the two computer systems and see if you can find any difference that explains the problem.

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
amaklop
post Aug 20 2019, 04:34 AM
Post#6



Posts: 26
Joined: 23-September 18



The one uses Outlook and the other uses Mailbird. The one using Mailbird was running fine until yesterday. I'm just not sure where to look for the issue ...
Go to the top of the page
 
theDBguy
post Aug 20 2019, 11:22 AM
Post#7


Access Wiki and Forums Moderator
Posts: 76,380
Joined: 19-June 07
From: SunnySandyEggo


If there's a MailBird forum, you might look in there. Just a thought...

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
amaklop
post Aug 20 2019, 12:53 PM
Post#8



Posts: 26
Joined: 23-September 18



Thanks smile.gif
Go to the top of the page
 
theDBguy
post Aug 20 2019, 12:55 PM
Post#9


Access Wiki and Forums Moderator
Posts: 76,380
Joined: 19-June 07
From: SunnySandyEggo


Good luck!

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 


Custom Search


RSSSearch   Top   Lo-Fi    15th October 2019 - 11:12 AM