UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Did The Windows Update Do That?    
 
   
MadPiet
post May 14 2020, 01:34 PM
Post#1



Posts: 3,772
Joined: 27-February 09



Hi,

I have weird things going on with this laptop - basically running out of space... not sure if it's relevant. I've been using Access since forever, and I had a really interesting thing pop up when I was trying to run some VBA...

CODE
Public Sub UnTwistMike(ByVal strTableName As String)
'-- grab the first couple of column names, assign colname to variable, insert into clean table.
    Dim tdf As DAO.TableDef
    Dim i As Integer
    Dim strCheckName As String
    
    Set tdf = CurrentDb.TableDefs(strTableName)
    Debug.Print tdf.Name
'    For i = 0 To tdf.Fields.Count - 1
'        Debug.Print tdf.Fields(i).Name
'    Next i

    Set tdf = Nothing
End Sub


When I run it, I get error 3420 - "Object invalid or no longer set." So either I'm doing something REALLY stupid, or my DAO library is screwed up. When I tried to run the code, Access crashed and quit completely - normally I would just get an error in the VBA editor window.

Everything was fine before the stupid Windows stealth Update. After that my computer just went nuts. (like my audio drivers suddenly stopped working)… I guess I just have to buy a bigger HDD and reinstall everything and that will fix it, right?
Go to the top of the page
 
DanielPineault
post May 14 2020, 02:57 PM
Post#2


UtterAccess VIP
Posts: 7,374
Joined: 30-June 11



I've seen a few posts related to Access suddenly crashing/closing?

Have you tried an office repair? Try reverting to another build no?

--------------------
Daniel Pineault (2010-2020 Microsoft MVP, UA VIP, EE Distinguished Expert 2018)
Professional Help: https://www.cardaconsultants.com
Free MS Access Code, Tips, Tricks and Samples: https://www.devhut.net

* Design should never say "Look at me". It should always say "Look at this". -- David Craib
* A user interface is like a joke, if you have to explain it, it's not that good! -- Martin LeBlanc


All code samples, demonstration databases, links,... are provided 'AS IS' and are to be used at your own risk! Take the necessary steps to check, validate ...(you are responsible for your choices and actions)
Go to the top of the page
 
MadPiet
post May 14 2020, 03:22 PM
Post#3



Posts: 3,772
Joined: 27-February 09



Daniel,

Haven't tried anything yet... was going to install a new SSD drive on this thing, but things are super complicated with the virus stuff. I could just reinstall/repair the install and see what happens. Worth a shot.

Pieter
Go to the top of the page
 
MadPiet
post May 14 2020, 05:42 PM
Post#4



Posts: 3,772
Joined: 27-February 09



Interesting.

When I go into Tools > References, DAO 3.6 wasn't checked/loaded. When I checked the box so it would load the library, I get "Error Loading DLL"... Oh Fuuuun...
So can I delete the DAO library and re-run repair?
Go to the top of the page
 


Custom Search


RSSSearch   Top   Lo-Fi    3rd July 2020 - 08:51 AM