Printable Version of Topic

Click here to view this topic in its original format

UtterAccess Forums _ Access Errors + Error Handling _ Database Errors Without Any Code Changes

Posted by: rusty1969 Sep 9 2019, 05:41 PM

I have an Access database at work, Access 2016 front end, SQL server backend. All was right in the world. We have an outside IT company that supports our company. They recently upgraded the version of another purchased database (BillQuick 2019). After they gave us the go ahead to resume after that "update"/"new version", my Access 2016 database is throwing errors without any code changes at all. Very simple lines of code using such things as "like" "instr" etc. throw errors like #func! and "out of memory". I made a copy of the database, converted all the tables to local tables, and ran on my computer at home and there are no errors, everything works great.

My first check on my work computer was the references, and they are all there, none are "missing". I also created a new database, imported all forms, queries, etc to start fresh, that didn't work either.
I asked the IT company to re-install microsoft office. Any ideas of what to ask them to check next? (the IT company has it all locked down, so it's very hard to troubleshoot with my privileges). i don't want them to start using the word "corruption". My feeling is that if no code has changed and it works fine on my home computer, it's not corrupted?

Can something have happened with the references? something in the registry? i know this is difficult because I don't know what they changed for this other database update -- they said that "nothing else needed to be changed" to update it. It's also a SQL backend. My database does use three tables from it, but i repointed the dsn, and linked the three new tables and all seemed 100 percent normal. and even the converted "local" table database throw errors on my work pc, but works at home. so i feel like i ruled out SQL and ruled out the code itself. ruled out the lack of a selected reference. feels like something wrong with the dll of the reference???? maybe?

please any suggestions on where to point the IT company?! (they get weirded out when it comes to access. and i know they are just going to say its corrupted!)

Posted by: Doug Steele Sep 9 2019, 06:20 PM

It certainly sounds like a References issue! You're positive they're okay? -

Can you compile the application cleanly?

Do you have the same problem with any other Access databases?

Posted by: rusty1969 Sep 9 2019, 06:38 PM

Yes, clean debug compile, all good. It really is the only access database we have, im the only one that uses access -- i provide an accdr file for other users to log on to db. I have opened previous versions and they all kick the same errors in the same spots. so again, it's not like it was a recent code change.

it does seem like references if the same exact non-linked local table database will work perfect on my pc at home but not at work!

Posted by: Doug Steele Sep 9 2019, 07:47 PM

Out of curiosity, what are the references? I seem to recall of a situation years ago where 3rd party software overwrote a DLL that Access used, thereby causing it not to work.

Posted by: rusty1969 Sep 9 2019, 08:14 PM

Snip attached of the references.

HOWEVER! As the local table database worked on my home pc, I created yet another a new database here at home, imported all objects into that (tested all worked), then logged on to my pc at work, saved that db on my work pc, deleted local tables, linked the SQL tables, and it now works again. Whatever. I love Access, but i lost two days messing around with this. And still don't really know what happened. On the bright side, Access does always teach me lessons in perserverence.

But thanks for your help!

 

Posted by: Doug Steele Sep 9 2019, 08:33 PM

Glad you got it fixed. hat_tip.gif

Not that it's particularly relevant, but to me, that seems to be a fairly large list of references. Do you really need references to both the Microsoft Office 16.0 Access database engine Object and the Microsoft ActiveX Data Object 6.1 Library? Could you use simply one of DAO or AOD? I'd suggest considering switching to Late Binding for Outlook, Word and Excel. I have no idea what RevuLauncher is.

Posted by: rusty1969 Sep 9 2019, 09:22 PM

Thanks... the activex was leftover when i was trying to troubleshoot, so definitely removed that. and i did just get rid of word and excel also with late binding.

the outlook, i gotta look into, not sure i can remove that one - but don't want to digress to another topic -- i am trying to add a "contact" (client) that gets entered into the database to a shared outlook contact file. still messing around with that code unsuccessfully. revu is a pdf app we use