UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Moving Controls On Form - Changes Do Not Stay, Access 2016    
 
   
RCDAWebmaster
post Feb 14 2020, 12:38 PM
Post#1



Posts: 110
Joined: 27-August 19



I have a form. I go to layout view and move a control. I save the form and close the form. When I open the form, the controls are where they were before I moved them. How do I get them to stay where I put them? Do changes of this sort only work in design view?
Go to the top of the page
 
theDBguy
post Feb 14 2020, 12:56 PM
Post#2


UA Moderator
Posts: 78,128
Joined: 19-June 07
From: SunnySandyEggo


Hi. Just some thoughts... If you go to layout view and move some controls around and then switch to design view, are the controls moved or not? Also, I'm not sure if you mentioned it, but when you're in layout view and moved controls around and then close the form, does it ask you to save your layout changes?

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
RCDAWebmaster
post Feb 14 2020, 01:00 PM
Post#3



Posts: 110
Joined: 27-August 19



It's not asking me to save in layout view since I always press the disk icon (save button) upper left hand corner of the screen (Quick access toolbar). If I move something and then go to design view, it is moved. If I move something in design view, save the form close and reopen, it stays put.
Go to the top of the page
 
theDBguy
post Feb 14 2020, 01:02 PM
Post#4


UA Moderator
Posts: 78,128
Joined: 19-June 07
From: SunnySandyEggo


Well, I just gave it a try and it worked for me. Try this little experiment. Go to layout view, move a control, don't click on the Save icon and simply close the form. Does it ask you to save? If so, say yes and then open the form to see if the control is moved or not.

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
RCDAWebmaster
post Feb 14 2020, 01:08 PM
Post#5



Posts: 110
Joined: 27-August 19



I went to layout view, moved a button, closed the form, was asked to save, said yes. When I open the form the button was where I put it. I then noticed that that the form itself is not as wide as it was as there is no space between the tab control and the edge of the form as there was a moment ago. I resized the form, closed and saved it, but it keeps auto sizing. out the space. maybe i need a hidden control to force space?
Go to the top of the page
 
theDBguy
post Feb 14 2020, 01:16 PM
Post#6


UA Moderator
Posts: 78,128
Joined: 19-June 07
From: SunnySandyEggo


Play with your form's AutoResize setting. Try setting it to No.

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
RCDAWebmaster
post Feb 14 2020, 01:21 PM
Post#7



Posts: 110
Joined: 27-August 19



I set auto resizing to no and now changes to the width in design view do not show in form view and I can't resize the form at all.
Go to the top of the page
 
RCDAWebmaster
post Feb 14 2020, 01:24 PM
Post#8



Posts: 110
Joined: 27-August 19



I figured it out i think. I had the border style set to none to get rid of the form title bar. I had to set the border to sizable, drag the form wider and then set the border style back to none.
Go to the top of the page
 
theDBguy
post Feb 14 2020, 01:25 PM
Post#9


UA Moderator
Posts: 78,128
Joined: 19-June 07
From: SunnySandyEggo


Hi. Glad to hear you got it sorted out. Cheers!

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
RCDAWebmaster
post Feb 14 2020, 01:27 PM
Post#10



Posts: 110
Joined: 27-August 19



Me too :-)
Go to the top of the page
 


Custom Search


RSSSearch   Top   Lo-Fi    1st June 2020 - 11:53 PM