X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
   Reply to this topicStart new topic
> App Only Works With Runtime 2013 And 2016 Installed, Access 2016    
post Mar 3 2019, 06:31 AM

Posts: 23
Joined: 1-May 18

I have an Access developed runtime application originally developed in Access 2010 but now in 2016 on my development machine.

I had to use Inno as the installer as the packager in 2010 is removed from 2016. All went fine until I installed it on a clean Windows 7 installation (no version of Office installed) with the office 2016 runtime. All appeared to go well until the first form (splash screen) attempted to open resulting in an error (2501, the open form action was cancelled). Thinking that this was either a reference issue (VBA) or an unregistered DLL or OCX I checked them all but this made no difference.

I had intended to use the 2013 Runtime as this works (apparently) with side-by-side installations of Office so I installed that on the Windows 7 machine forgetting that the 2016 Runtime was already installed.

The installation on the Win 7 machine then worked straight away with no errors at all.

Strangely it won’t work with just 2016 Runtime 0r 2013 Runtime installed on their own, but only with both installed. Anyone know why?

Development machine is Windows 10 fully patched. Target machine clean Windows 7 fully patched (well it’s not clean now).

The application is split into a front and back end database with a boot loader database that opens the front end which is encrypted as is the back end. I noticed that the encryption in 2016 may be slightly different to 2010 but have not perused this path as yet.

Whilst I’m here does anyone know how to change Access 2016 theme to something that’s not all white or white with a red title bar as it’s causing me bad headaches, also to start Access as the 2010 version as this is a pain in the neck traversing back to the main ribbon so that compact and repair is available?
Go to the top of the page
post Mar 6 2019, 08:53 AM

Posts: 23
Joined: 1-May 18

Well the above issues I encountered have now been resolved, what actually caused them is still a bit of a mystery.

1 Issues with the encryption used in Office 2016 being incompatible with Office 2010 encryption causing problems with record locking. Each database had to have the encryption removed and then put back again.
2 When the 1016 runtime or 3013 runtime installed under Windows 10 and then the installer ports this to Windows 7 random errors were produced such as automation issues, forms would not open… repeated error 2501’s and invalid use of null and so on.

None of the above were actual errors requiring the code to be fixed but what I call environment issues.

The fix was to move the entire development to a Windows 7 machine with Office 2016 installed and VB.NET which I use to install the application along with INO for the Access part.

However I can’t answer exactly why an app compiled on Windows 10 would only run on Windows 7 when both the Access 2013 and 2016 runtime were both installed, I suspect the answer is out there somewhere.
Go to the top of the page
post Mar 25 2019, 09:09 AM

Posts: 23
Joined: 1-May 18

This is an update regarding the first post.

Further research has yielded new possible reasons for the odd behaviour where Access would only run when the runtime for 2016 and 2013 were installed.
This only came to light after compiling in Windows 7 and then attempting to install on two separate Windows 10 machines, one of these machines (the one with both runtimes installed initially but now with only the 2016 runtime) produced the same errors as originally reported i.e. automation errors and when trying to open a particular form stating that the object does not support this property or method.

There was nothing in the Windows logs to indicate that there were any issues with this machine however I remember the user a few months ago complaining that when streaming programs for the BBC iPlayer it was stuttering all the time and on occasion the sound would be out-of-sync with the picture.
Anyway putting the two items together I decided to check out the WMI interface which appeared fine - but it was not… I rebuilt it and everything then worked. I did the same to the Windows 7 compilation machine… this also had WMI errors which I had not checked for (it was a clean install) and since then the app installs o.k. on any machine.

There is a generic automation error message -2147467259, if you see this then re-build the WMI service. If you’re lucky there may be entries in the Windows log, then again not.
Having now tested all the machines for WMI issues 50% needed WMI to be fixed.

WMI provides users with information about the status of local or remote computer systems. It also supports such actions as the configuration of security settings, setting and changing system properties, setting and changing permissions for authorized users and user groups, assigning and changing drive labels, scheduling processes to run at specific times, backing up the object repository, and enabling or disabling error logging. The WBEMTest.exe tool also did not find any errors in WMI and fsc /scannow also reported that everything was o.k. when it clearly was not.
Go to the top of the page

Custom Search

RSSSearch   Top   Lo-Fi    14th November 2019 - 02:29 PM