X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
   Reply to this topicStart new topic
> Unable To "add New" On View, Access 2013 Web App    
post Aug 9 2017, 11:20 PM

Posts: 6
Joined: 24-May 17

HI All

Another Access Web App Problem, I am not surprised they are getting rid of it!

Error 2046 - The command or action isn't currently available.

Also, the + has been greyed out so I cannot add a new record, if i go through a button/popup I can add a new record to the same table.

The main view is linked to one table only, the table is not locked.
There are 3 Related Item Controls within the main view, all linking through on the ID field and work as they should.

I also remade the form and checked each step at a time. It all worked until I came back this morning and the same thing has happened

I cannot see any reason for it not too work but it isn't

Has anyone else experienced this or any advice?


Go to the top of the page
post Aug 11 2017, 08:56 AM

UA Admin
Posts: 37,633
Joined: 20-June 02
From: Newcastle, WA

Unfortunately, we don't seem to have an answer here.

Frankly, though. I would have to disagree with your sentiment about AWAs. They are, in my experience, easily the best of class in their niche. You are right that they are not perfect nor even problem-free. But for the cost ($5.00 a month for an O365 account), ease of use, power and functionality, nothing else currently available comes close. Replacing them is going to cost serious developers a lot of time and money. Trust me, I'm doing just that right now with my own.

That said, the most likely problem here is that some Data Macro is running in this AWA, possibly at StartUp, which is getting the AWA into this state. I make that guess based on your saying it worked until you closed it and restarted it the following day.

Trouble-shooting is harder in this environment than in VBA, and your available tools are more limited, but there is one that might help find your problem.

Attached File  CheckYourOnStartMacro.png ( 9.36K )Number of downloads: 0

Attached File  TurnOnMacroTracing.png ( 14.59K )Number of downloads: 0

Attached File  ErrorMessagesIfAny.png ( 77.74K )Number of downloads: 1

If there are any error messages, that would be a clue as to what might be causing the problem.

If not, of course, knowing what macro steps were processed can be useful in tracking down the place where your DMs possibly went off the tracks.

Another consideration is that there could be something amiss in your SharePoint site on Office 365. If nothing else turns up, it's time for a support call to Microsoft.

And, as a really drastic last step, if you want to share the app package, I could install and inspect it for you.
Go to the top of the page

Custom Search

RSSSearch   Top   Lo-Fi    6th August 2020 - 11:39 AM