UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
2 Pages V < 1 2  (Go to first unread post)
   Reply to this topicStart new topic
> Need Help! Acess 2007 Rt "crashes" On Windows 10, Access 2007    
 
   
merlenicholson
post Nov 8 2018, 01:49 AM
Post#21



Posts: 526
Joined: 23-November 11
From: Tampa, Florida, USA - UTC -5:00


So I don't see how sending the client the A2K13RT to see if that might help solve the problem he was having, is any different that a client with Access 2013 installing MyApp and having it run just fine with Access 2013. I would appreciate your thoughts on this Merle.

I'd also appreciate you further explaining your last suggestion (highlighted above in bold). Are talking about the P&D feature included with Access 2013 or some other deployment package???


Yes, the Access P&D is the only deployment app that I'm familiar with, and I've used it very successfully.

When you sent the A2013RT for installation, it was successful, but that doesn't necessarily make it a good practice. Your app should be launched to the specific RT that it is designed for. Since it's not your PC you can't guarantee that the client won't install other apps and other versions of Access. The client could be totally unaware that an app is even running under Access. Since you can install multiple versions of Access 32 and 64 bit, you would have some difficulty guaranteeing that your app will work! Probably not a good situation, but it's not your PC.

The P&D sorts this out by creating a startup icon that invokes the RT that you specify on installation and hands the app pathname as a parameter.

So I think that the app should always be run by the RT it is specifically compiled on, packaged and deployed together. It also gives the client a chance to reinstall cleanly on his PC or on a replacement PC.


--------------------
Merle Nicholson
Ninety percent of all mental errors are in your head. - Yogi Berra -
Go to the top of the page
 
ztatzau
post Nov 9 2018, 12:28 PM
Post#22



Posts: 337
Joined: 4-April 07



Thanks Merle! I appreciate your reply!

I've previously used the built-in P&DWs from Access 2.0 through Access 2007. I then switched over to SSE setup for my deployments specifically so that myApp's setup could be used to reinstall my program on replacement computers that may not be configured the same as the client's original computer. This has worked out well for quite a few years!

Last time I looked into it, Access 2013 no longer included a built in P&DW. Has this changed? Or, is your experience with the built in Access P&DW limited to Access 2010 and prior versions?

PLMK! ZT
Go to the top of the page
 
2 Pages V < 1 2


Custom Search


RSSSearch   Top   Lo-Fi    20th November 2018 - 12:58 PM