UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Report Content Shifting After First Record, Access 2016    
 
   
Psycoperl
post Oct 16 2019, 03:52 PM
Post#1



Posts: 429
Joined: 11-March 15
From: Somewhere lost in the NY Subways


Hi all ... I have a report which is a two page form letter.

The funny thing that is happening is that after the first record, content is displayed aprox 1/4 inch higher than it was for the first record.

There are NO page headers or report headers.

Any suggestions/thoughts?
Thanks
Go to the top of the page
 
June7
post Oct 16 2019, 04:33 PM
Post#2



Posts: 1,013
Joined: 25-January 16



Not without seeing report design. If you want to provide db for analysis, follow instructions at bottom of my post.

--------------------
Attachments Manager is below the edit post window. To provide db: copy, remove confidential data, run compact & repair, zip w/Windows Compression.
DEBUG! DEBUG! DEBUG! http://www.cpearson.com/Excel/DebuggingVBA.aspx
Go to the top of the page
 
tina t
post Oct 16 2019, 04:35 PM
Post#3



Posts: 6,182
Joined: 11-November 10
From: SoCal, USA


are you using a page-break marker?

hth
tina

--------------------
"the wheel never stops turning"
Go to the top of the page
 
Psycoperl
post Oct 16 2019, 06:41 PM
Post#4



Posts: 429
Joined: 11-March 15
From: Somewhere lost in the NY Subways


Tina. Yes there is a page break marker between pages 1&2 (for front and back)
Go to the top of the page
 
tina t
post Oct 16 2019, 06:46 PM
Post#5



Posts: 6,182
Joined: 11-November 10
From: SoCal, USA


hmm, well, it can cause a spacing problem, depending on exactly where it is physically placed in the report, in Design view. try moving it up or down, just a little. or, if it's at the bottom edge of a report section, make sure it's really snugged up to the bottom edge, no space below. ditto if it's at the top edge...

hth
tina

--------------------
"the wheel never stops turning"
Go to the top of the page
 
Psycoperl
post Oct 17 2019, 12:44 PM
Post#6



Posts: 429
Joined: 11-March 15
From: Somewhere lost in the NY Subways


@june7 -- i am attaching a mini db that contains the report and the related elements only.

Attached File  database_demo_db1.zip ( 572.57K )Number of downloads: 4
Go to the top of the page
 
June7
post Oct 17 2019, 04:41 PM
Post#7



Posts: 1,013
Joined: 25-January 16



Did not include folder with QRcode images.

First page has about 1/2" blank area at beginning. This spacing is not in second page. Move page2 controls down to include some white space at beginning after pagebreak or move first page controls up and adjust PageSetup margins.

Hard to run report with all those static path constants.

This post has been edited by June7: Oct 17 2019, 05:02 PM

--------------------
Attachments Manager is below the edit post window. To provide db: copy, remove confidential data, run compact & repair, zip w/Windows Compression.
DEBUG! DEBUG! DEBUG! http://www.cpearson.com/Excel/DebuggingVBA.aspx
Go to the top of the page
 
Psycoperl
post Oct 17 2019, 05:15 PM
Post#8



Posts: 429
Joined: 11-March 15
From: Somewhere lost in the NY Subways


Hi june7

The qrcodes are actually created via vba on demand.

The issue is when it goes to pages 3, 5, 7, etc... of the report as that would be page 1 of the next record.
Go to the top of the page
 
June7
post Oct 17 2019, 06:09 PM
Post#9



Posts: 1,013
Joined: 25-January 16



I disabled all QRcode code so I could run report.

Set Detail section ForceNewPage property to AfterSection.


--------------------
Attachments Manager is below the edit post window. To provide db: copy, remove confidential data, run compact & repair, zip w/Windows Compression.
DEBUG! DEBUG! DEBUG! http://www.cpearson.com/Excel/DebuggingVBA.aspx
Go to the top of the page
 


Custom Search


RSSSearch   Top   Lo-Fi    9th December 2019 - 10:25 PM