X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
2 Pages V < 1 2  (Go to first unread post)
   Reply to this topicStart new topic
> Access 2007 Bug List    
post Oct 29 2008, 02:07 PM

Posts: 1
Joined: 29-October 08

Have you heard of this one...
I have a 2003 Acccess DB that runs great. Recently I opened it in Access 2007 to make sure everything was working ok and came across this issue.
I am able to run all queries /reports, however, when I attempt to open a query in design view that is based on more than 1 table I get the error " is not a valid name...
I only have 3 tables, all are linked, 1 to a SQL DB and the other 2 are linked to a backend Access DB on our network. I am able to open all tables and can run all queries /reports, can view my queries in SQL view also.
I also get this error when attempting to open the Relationships window.
I called Microsoft and today they told me this is a bug (ref #37769) but they have not yet released a fix.
Does anyone know of a work-around for this?
Go to the top of the page
post Feb 15 2009, 04:28 AM

Posts: 14
Joined: 29-January 09


Using a treeview control in a report causes a 'false' error-messages (error 2926) when the report is opened by code in preview mode:

DoCmd.OpenReport "Rpt_Tree", acViewPreview

This might be another bug.

For further details look here

If someone knows wether this is a true bug or can explain this, please let me know.
Go to the top of the page
post Mar 30 2009, 01:10 PM

Posts: 648
Joined: 31-July 03
From: Central Illinois

I have just tried to use the Microsoft Hotfix for this error:
!--coloro:green-->The format in which you are attempting to output the current object is not available.
Either you are attempting to output the current object to a format that is not valid for its object type, or the formats that enable you to output data as a Microsoft Excel, rich-text format, MS-DOS text, or HTML file are missing from the Windows Registry. Run Setup to reinstall Microsoft Office Access or, if you’re familiar with the settings in the Registry, try to correct them yourself. For more information on the Registry, click Help.

It did not seem to help :(
Has anyone else had any luck with this one?
Go to the top of the page
post Apr 16 2009, 08:53 AM

Posts: 1
Joined: 16-April 09
From: Maryland, USA

I've recently purchased Office 2007 Pro and successfully converted all my Access 2003 databases to Access 2007. However, after running fine for a few days, I get the error message ACCESS HAS ENCOUNTERED AN ERROR AND MUST CLOSE. Then WAIT WHILE SEARCHING FOR A SOLUTION. It has happened to three of my databases so far.
can't re-open these databases anymore. Each time I try Access asks for a place to backup the database and then it aborts again with the same message above.
Two questions:
1. How can I get into the database again to troubleshoot? and,
2. When I do, how can I figure out what is causing the problem?
Go to the top of the page
post Dec 10 2009, 05:45 AM

Posts: 28
Joined: 10-December 09
From: Buskerud, Norway

As seen on other forums as well, there is a problem with SP2. The status bar starts flickering, saying "Updating tables. Press and hold ESC to abort". This flickering does not affect performance too much when running by one user only. But when using runtime version for a second user, it practically freezes everything up. This update-message appears every 4 seconds. Anyone who knows if there is a fix for this issue?
Go to the top of the page
post Dec 10 2009, 08:21 AM

Posts: 28
Joined: 10-December 09
From: Buskerud, Norway

I've just found the hotfix myself. Valid for both runtime and full version:
Go to the top of the page
post May 12 2010, 01:48 PM

Posts: 39
Joined: 12-January 04
From: Atlanta

VARGAN : Your reference to KB/973405 may be helpful, but I was unable to determine the Hotfix addressed the "Updating Tables. Press nad Hold ESC to abort" message. Can you confirm the hotfix addressed the problem?
Go to the top of the page
post May 12 2010, 02:54 PM

Posts: 652
Joined: 12-June 07
From: Auckland, New Zealand

A qualification of this bug.........
If you use
Docmd.transferDatabase aclink, ....... this will expose the Navigation pane
A workaround is to use
Set TDF = .CreateTableDef(strLocalName)
TDF.SourceTableName = strSourceName
TDF.Connect = ";DATABASE=" & strBackEndPath
this doesn't expose the navigation pane.
Go to the top of the page
post Jun 14 2010, 07:58 AM

Posts: 28
Joined: 10-December 09
From: Buskerud, Norway

The hotfix did address the error described by you (and me) yes.
Go to the top of the page
post Jun 14 2010, 08:28 AM

Posts: 39
Joined: 12-January 04
From: Atlanta

Thanks. Confirmed same and have been running in production for several weeks.
Go to the top of the page
post Sep 14 2010, 06:21 PM

UtterAccess VIP
Posts: 4,892
Joined: 25-September 02
From: Washington State

1) When I used a custom Ribbon command to run code in a reference database, all sorts of crazy errors happened. When I tried calling the code instead from a command button on a form, everything went great.
) Having a great deal of trouble with a database that hangs almost every time I close it -- must go to Task Manager to get rid of it. It has 2 reference DBs (one is an accdb and one is an mda.) I have an Exit button with code to close all open forms (and reports) and then Quit the application, which doesn't seem to help. I can't put this DB into production until I find a solution. The code for "closing up shop" always worked in previous versions, with or without Access reference files.
This is WinXP, A2007, running DB that is 2000 file format.
Continued to have problems with crazy error messages after giving up on the Ribbon, but all of the problems with databases hanging and other crazy errors were eventually resolved by decompiling the databases that developed the problems when they were opened with 2007. Since decompiling and recompiling, everything's going fine, except I have not tried again to use a custom ribbon command.
Go to the top of the page
post Oct 7 2010, 08:28 AM

Posts: 22
Joined: 6-October 10

The replication "feature" of Access 2007 does not work for Access 2002-2003 databases.
ccording to the common wisdom, for replication to work you must do the following:
1) Use an *.mdb database
2) Use an autonumber field in each table
3) Split the database into FE and BE parts
4) Create the replica from the BE DB only
5) After creating the replica, do not move the location of either the master DB or the replica
With all these factors being met, replication still does not work.
CAn informational message appears:
"Microsoft Access can't retrieve information from the replica ... (replica name)"
great work Microsoft.
Go to the top of the page
post Oct 10 2010, 11:52 AM

Posts: 307
Joined: 19-April 04
From: Toronto

Has anyone else found that copying and pasting a record in both continuous and form view forms to a new record results in garbage being pasted?
Go to the top of the page
post Aug 4 2011, 03:41 PM

Posts: 165
Joined: 11-December 02
From: Charleston, SC

Discovered incorrect Control Tip text messages: All my FormClose buttons were reading "Apply Filter". Changed the text on the property sheet, saved the form, opened the form all was good...until the form closed. Upon re-opening, the control tip text had reverted to "Apply Filter" I guess closing a form is a filter of sorts.
Go to the top of the page
post Sep 20 2019, 03:53 AM

Posts: 1
Joined: 20-September 19

There is a new bug with Microsoft access reporting in an unrecognized format. Some people also report that this change has had a negative impact on access. I was also working on it and it was showing a text written as MS Office 2013 error 0x4004f00d. Then I got the solution by my own . It is very easy to solve it. If you felt like this ever can check it out.
Go to the top of the page
2 Pages V < 1 2

Custom Search

RSSSearch   Top   Lo-Fi    7th August 2020 - 10:39 PM