X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
3 Pages V < 1 2 3 >  (Go to first unread post)
   Reply to this topicStart new topic
> Access 2003 Bug List    
post Aug 5 2004, 10:08 AM

UA Administrator
Posts: -8,388,309
Joined: 21-April 01
From: Right here.

Typicaal FE-BE configuration.

Pulled a copy of the FE to work on at home (I just need to get in and check a module), so of course the links to the BE are invalid.

Start the Db on the shift key. Assure or in this case as I had been using 'error checking' on a tiny Access Db previously, that 'Error Checking' is off.

Try to do anything with the Db. Anything meaning open a fairly heavy form in design view to try to get to the VBA module - impossible.

It appears that either the error checking is still checking, or it's upset because the linked tables are nowhere to be found - beats me but it sucks the living life out of this computer (P3 1.2 1Gb ram). It may eventually return once it's done what ever it's doing, but I'm sorry, I can't wait a half hour to open one form.

A virtual twin FE copy with locally linked tables and error checking ON, will spool up the form and module about as fast as you click.

SP2 please?


Go to the top of the page
post Aug 16 2004, 08:16 AM

Posts: 229
Joined: 18-September 03
From: Halifax, United Kingdom

I have fixed my initial problem of the UNKNOWN box appearing when you try and do anything in Access.
But the following in the RUN bar and press enter.
regsvr32.exe c:\WINDOWS\system32\Msjtes40.dll
It should run successfully and you can then carry on as normal.
Ogot the solution from a distant and unrelated knowledge base in Microsoft ever so helpful knowledge base. Took over 400 files to get to the right one. I can't remember the actual file name, I keep this in the history of my run menu and have needed to run it twice in total.
Cheers for those suggestions from other users.
Go to the top of the page
post Aug 18 2004, 02:37 PM

Posts: 3
Joined: 18-August 04

I have had a similiar problem. An Access 2000 database will open fine in Access 2002 but not in 2003. I would get a system error message that indicates a problem in VBE6.DLL. I did a search in support.microsoft.com and found an article (827319) about a problem with this DLL in Powerpoint. I used the same process to fix Access 2003. Turns out that I had a missing reference to Utility.MDA. After I removed this, I could open the database.
asically this is what I did:
1. Quit Access 2003.
2. Click Start, point to Search, and then click For Files or Folders.
3. Type Vbe6.dll as the file name, and then click Search Now.
4. Click Start, and then click Run.
5. Type regsvr32 /u in the Open box. Make sure that you include a trailing space after the "/u".
6. Drag the Vbe6.dll file from the Program Files\Common Files\Microsoft Shared\Vba\Vba6 folder in the Search Results box to the Run box after the "/u". The Open box now looks similar to the following: regsvr32 / u "C:\Program Files\Common Files\Microsoft Shared\Vba\Vba6\Vbe6.dll".
7. Click OK. You receive a message that states that the operation succeeded.
8. In the Search window, right-click the Vbe6.dll file that you used in step 6, and then click Rename.
9. Rename the file to Vbe6.old, and then close the Search window.
10. Start Access 2003.
11. If you are prompted to repair the installation, click No.
12. On the Tools menu, point to Macro, and then click Visual Basic Editor.
13. Click Yes when you are prompted to repair.
14. Open database
13. On the Tools menu, point to Macro, and then click Visual Basic Editor.
14. In Visual Basic Editor, Select Tools Editor
15. Resolve missing referneces by removing or fixing the entry.
Go to the top of the page
post Nov 5 2004, 11:25 AM

Posts: 426
Joined: 8-September 02
From: Round Lake, IL

Regarding the time it's taking to open a form w/ bad table links, there *may* be a way to bypass the linked-table check.
Go straight from Access to the VBA IDE, use project explorer to open the form's code. My presumption is that the form - or something on the form - is bound to the table in question. So each time the form's open in design view, Access just has to check the control/record source. I'm also guessing that the ~linked~ table would be on a network share. From my experience, Windows will keep trying to re-establish the network connection, long after patience runs thin.
My other presumption is that if you open the code from the VBA IDE that the other parts of the form that would try to re-establish the missing link would not be called.
It's a stab in the dark, but if it works...
Good luck,
Go to the top of the page
post Dec 8 2004, 05:19 PM

Posts: 1
Joined: 6-December 04

While testing one of our new machines loaded with Office 2003, it seems that Access is not able to open/create a report in "design view" when running out of a certain user profile. The PC is running Win2000Pro (SP4), and has Office2003(SP1). Basically, I can simulate the problem by following the steps below:
1.) Open Access 2003.
2.) Create a new database. (I just use db1 for testing)
3.) Go to the Reports window.
4.) Doubleclick "Create Report in Design view"
After step 4, nothing happens. There is no hangup or error given by the application. Seems like empty code or something is being bypassed. I even tried to import an existing report into the database and tried opening it up in design view to no avail.
Oclassified this as a bug since you supposed to be able to open up even a blank report window in design view. All versions of Access allow you to do this normally.
It's strange that if I logon as user "Administrator" or another user, the problem does not occur and design view works. I am wondering if there is a profile permission conflict, or a library reference problem here. Has anyone had a similar problem?
Any info would be helpful. Thanks.
Go to the top of the page
post Dec 29 2004, 03:17 PM

Posts: 1
Joined: 29-December 04

I had this problem as well and when I changed my default printer from a network printer (shared via a Linux Samba Print Server) to an IP printer (or to PDF Writer) I was suddenly able to access reports again. Both design view and wizard work fine now. Apparently this was a problem in Access 2000 as well and MS hasn't fixed it yet.
Go to the top of the page
post Feb 8 2005, 02:14 PM

Posts: 1
Joined: 3-November 03

Did you ever find a solution for the printing error in Access 2003 (the open report action was cancelled..) I am seeing this same situation in a database system with users in 2003 and I have tried uninstalling/reinstalling printer drivers and changing default printers.. (the same printer drivers work for other users on other machines using the same mde file...) AND this user was able to print until not too long ago.. Would love any input.. Do you know if the SP-1 patch for Office 2003 has addressed this issue? Thanks
Go to the top of the page
post Feb 22 2005, 03:07 PM

Posts: 4
Joined: 22-February 05

I'm not sure if the cause so I'm fishing for an answer here. I've got a 2003 access db with multiple SQL liked by ODBC. I open one after the other view. Then just a single click, or an attempt to rename a table, will cause the DB to spontaneously close.
o warning, no error. Nothing. The mdb opens again fine, no warning of corruption.
Any clues?
Go to the top of the page
post Mar 29 2005, 06:53 AM

Posts: 177
Joined: 29-March 05
From: Yorkshire Dales, England

I've only noticed this with Access 2003. Sometimes when I quit out of Access (say after a compile) I cannot load Access back in. Instead I have to bring up the task list (Ctrl Alt Del) and remove the still running Access task. Then it loads it back in fine. Oddly this same bug used to happen with Excel 2002. I have been using Access 2002 on the same machine (before upgrading) and have never had the problem before. I have been using Access since 97 and never has this issue before.
Go to the top of the page
post Apr 4 2005, 06:19 AM

Posts: 1,186
Joined: 22-November 02
From: Nashville, GA

Having the same problem with Access 2000, on my home computer and work computer. Any ideas?
Go to the top of the page
post Apr 4 2005, 06:30 AM

Posts: 177
Joined: 29-March 05
From: Yorkshire Dales, England

Actually I may have cured the problem. It MIGHT be Powerstrip. Last week I knocked off all odd-ball tools running in my system tray - which wasn't really that many - Powerstrip - a hotkey tool (for my laptop) and a piece of 3D sound software that also came with my laptop.
Everything seems okay now. I think the culprit is PowerStrip. I will continue to test and let you know how I get on.
Go to the top of the page
post Apr 4 2005, 10:59 AM

Posts: 177
Joined: 29-March 05
From: Yorkshire Dales, England

I spoke too soon. The problem has occurred again!
Go to the top of the page
post Apr 5 2005, 09:24 AM

Posts: 177
Joined: 29-March 05
From: Yorkshire Dales, England

I've tried removing all system tray programs but the problem still stays. It doesn't trigger an error report either so perhaps MS are unaware? It just hangs as a task in the task list. I wonder what could stop a program properly closing? It is as if Windows doesn't completely release the task for some reason.
Go to the top of the page
post Apr 22 2005, 03:40 AM

Posts: 1
Joined: 22-April 05

You Star! thumbup.gif
Since I migrated from Access 2000 to Access 2003 I havent been able to use Access at all. Access would start OK but crash as soon as I tried to do something. Even opening a blank database, created by Access 2003 itself would crash after about 5 secs, generating a bug report with error exception code 0xc0000005 in it. Nothing would make it work! giveup.gif
Odid all the things you're supposed to - re-install, update, update Jet etc - Nothing (Arrrh!!).
egistering this file did it - Thanks a million
BTW, could you post the url of the "distant and unrelated knowledge base in Microsoft". Others (& me) may find whats in it useful too thanks.gif
Go to the top of the page
post Apr 27 2005, 02:54 PM

Posts: 245
Joined: 14-March 05

I had this exact same problem just now.
had a network printer installed and was using the PCL driver for that printer. Changing to the PS driver for the printer solved the problem.
I would like to thank this forum because it is here where I found the idea of what was wrong and how to fix it.
Go to the top of the page
post May 6 2005, 11:56 AM

UtterAccess VIP
Posts: 1,575
Joined: 19-December 02
From: Lansing, MI

Access 2003 keeps losing many of its built-in command bars. This has happened to me three times only in version 2003, never in previous versions. The only thing that fixes it is completely uninstalling and re-installing Access 2003. But soon after re-installing it will suddenly happen again.
For example, I will get no Form Design or Query Design command bars when I open a form or query in design view. When I go to Tools | Customize the Form Design and Query Design bars are not even in the list. If I go to the immediate window and try to reference these command bars through the CommandBars collection, I can successfully retrieve the Name property so somehow Access still knows they exist, but when I try to set Visible to True, a message box pops up that says :"Unknown Error"
Oalso run into problems exporting objects from one database to another. I will right-click the object to export and after choosing the destination, the export window just closes without doing anything or giving me any messages. If I was trying to export table or query results to text it won't even bring up the export wizzard. I can fix this problem by doing a Detect and Repair but it eventually starts happening again.
Go to the top of the page
post May 25 2005, 04:19 PM

Posts: 2
Joined: 18-April 05

I have a subform driven by a query. If any changes to the subform are made (such as sorting records) the sql in the query is reset to:

It causes the main form and the subform to fail when re-opened when this happens. Sorting records in a form datasheet shouldn't obliterate the SQL behind it.
Go to the top of the page
post Jul 8 2005, 06:27 PM

Posts: 1,809
Joined: 14-March 00
From: Ayrshire, Scotland

Ive converted a mdb front end from 2000 to 2003.
Several reports that print envelopes with vertical fields now print lots of blank pages in addition to the pgae with data. The margins etc are ok and the thing worked fine in A2000.
I've solved the problem by rebuilding the reports in 2003.
Is this a known conversion problem? Is there a fix so I don't have to rebuild any more reports?
Thanks very much.
Go to the top of the page
post Oct 14 2005, 12:39 PM

Posts: 71
Joined: 19-September 05

Hello everyone. I have a database that is already completed. When I finished the project, everything was working properly, now after a week of being live, things aren't working the way that they were. A couple examples:
) I have a Form/subform, where the subform can have one or more records displayed attached to the person's name and information displayed in the main form. The users can enter new records in the subform, or update the ones that are already there. I noticed recently that none of the records in the subform are showing up. When I enter a new record in the subform, then go check the table where those records reside, the record is there with all the correct information, however when I go back to the form/subform, that record isn't showing up. In fact, no records display in the subform.
2) I have a report that displays contact information like name, address, phone, etc. Some of the values are not complete, like the last character is getting cut off, and its not a spacing issue, because some of the values that are longer display just fine. This report was working fine a couple weeks ago, now that flaw shows up.
3) After some time, eventaully some reports will print a blank page in between each page, the blank page will have 2 sets of quotation marks on it and nothing else.
All these problems can be fixed I noticed if I simply re-build them. However, my form/subform does have some code running on it, and its no big deal for me to just copy and past it over to a newly re-made form, but whats going to happen after I leave this job? The next person isn't going to know that they are supposed to re-build the forms, and reports or how to do it for that matter. Also, I shouldn't have to rebuild all my applications every couple of weeks because they were working fine, and now they don't. This violates the whole spirit of Access, building WORKING applications fast.
Any suggestions would be greatly appriciated.
Go to the top of the page
post Oct 18 2005, 02:40 PM

Posts: 71
Joined: 19-September 05

Update, the report issue was in fact a spacing issue after all. So that was no big deal, however I had to re-build the form/subform and it works but I still don't know why this happens and how to prevent it in the future.
Go to the top of the page
3 Pages V < 1 2 3 >

Custom Search

RSSSearch   Top   Lo-Fi    14th December 2019 - 09:09 PM