UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Bar Charts Doesn't Display Alll Bars, Access 2003    
 
   
youngb
post Jun 15 2019, 03:16 AM
Post#1



Posts: 579
Joined: 2-September 03
From: Galway, Ireland


Hi,

I have been successfully using the charts in both Access 2003 and 2007 for quite some time, even though the behaviour can be a little unpredictable at times, currently I am using a bar chart to display the number of days of machine in production,
pretty straight forward enough but the slight unexpected behaviour is that when I make the Chart bigger in width, from 22cm to 23 cm it drops the last Machine, i.e Machine # 30, and continues to drop more machines as I make the width bigger.
See the attached report: R_PRODUCTION_ORDERS_PER_MACHINE_22_CM.pdf at a width of 22 cm shows all the 30 machines, but the Report: R_PRODUCTION_ORDERS_PER_MACHINE_27_CM.pdf at a width of 27 cm only displays the first 25 machines and drops the last 5. See attached pdf.

To add to the problem this problem doesn't occur on the original computer it was created but does occur on my laptop and most importantly on all the clients 4 computers which used access runtime 2007 and Windows 7.
Now I know that the Print Preview is mostly dependent on the 'Default Printer' so I am using the same default printer: 'Microsoft XPS Document Writer' as the computer that it works on and I still get the same problem.
So I have also attached the mdb file containing the Report: 'R_PRODUCTION_ORDERS_PER_MACHINE' to illustrate what I am saying but I don't know if someone will get the same issue of not.
Now the mdb open to a form with the button: 'Open Report'

Thanks in advance for anybody who takes time to look at this cryptic problem and any useful suggestions.

Regards
Brian



Attached File(s)
Attached File  R_PRODUCTION_ORDERS_PER_MACHINE_27_CM.pdf ( 13.7K )Number of downloads: 4
Attached File  Orders_Per_Machine_Demo.zip ( 636.12K )Number of downloads: 10
Attached File  R_PRODUCTION_ORDERS_PER_MACHINE_23_CM.pdf ( 14.04K )Number of downloads: 4
Attached File  R_PRODUCTION_ORDERS_PER_MACHINE_22_CM.pdf ( 13.82K )Number of downloads: 4
 
Go to the top of the page
 
ADezii
post Jun 15 2019, 12:01 PM
Post#2



Posts: 2,461
Joined: 4-February 07
From: USA, Florida, Delray Beach


Works fine on my PC, do you have the Size Mode Property of Graph0 set to Stretch?
Go to the top of the page
 
June7
post Jun 15 2019, 02:53 PM
Post#3



Posts: 653
Joined: 25-January 16



Downloaded your db. Opened report and it shows fine. Switched to design view and shows bars cut off. I double clicked on the graph and it resized. Did the same thing with Report1 and Report2. Even with Writer set as default printer.


This post has been edited by June7: Jun 15 2019, 03:39 PM

--------------------
Attachments Manager is below the edit post window. To provide db: copy, remove confidential data, run compact & repair, zip w/Windows Compression.
DEBUG! DEBUG! DEBUG! http://www.cpearson.com/Excel/DebuggingVBA.aspx
Go to the top of the page
 
youngb
post Jun 16 2019, 12:34 PM
Post#4



Posts: 579
Joined: 2-September 03
From: Galway, Ireland


Hi Guys,

Thanks for the suggestions, tried both those, thought it might be the problem, but neither seem to have solved the problem, it has to be some small odd thing

Regards
Brian
Go to the top of the page
 
youngb
post Jun 17 2019, 11:08 AM
Post#5



Posts: 579
Joined: 2-September 03
From: Galway, Ireland


Hi Guys,

Got it working on another PC, must be something to do with that particular PC and the Particular Installation of Access, maybe I will remove and re-install.
Thanks again for all the helpful suggestions.

Regards
Brian
Go to the top of the page
 


Custom Search


RSSSearch   Top   Lo-Fi    20th July 2019 - 07:20 PM