UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Why rows not closer together    
 
   
WSplawn
post Sep 30 2008, 10:58 AM
Post#1



Posts: 1,913
Joined: 1-August 07
From: Sacramento California


I have a tabular report. I would like for there to not be much space between the rows, but have not figured out how to get the rows so that they look like they are right next to each other. There always seems to be more space between the rows than I want.
On design mode I have eliminated all space above and below the textboxes in the details section. I thought it might have to do with padding or margins so I highlighted all the textboxes and put a zero value in all padding and margin properties. The rows still come out with more space between them than I would like.
Would someone explain to me what I am missing?
Thank you
Go to the top of the page
 
RAZMaddaz
post Sep 30 2008, 11:09 AM
Post#2


UtterAccess VIP
Posts: 9,601
Joined: 23-May 05
From: Bethesda, MD USA


Have you tride making the Height of the Detail section smaller?
Go to the top of the page
 
WSplawn
post Sep 30 2008, 11:13 AM
Post#3



Posts: 1,913
Joined: 1-August 07
From: Sacramento California


The hight of the detail section is as small as it will go. I can not drage the bar any further up and the size of the fields are as small (short) as they can get without truncating the values.
Go to the top of the page
 
RAZMaddaz
post Sep 30 2008, 11:18 AM
Post#4


UtterAccess VIP
Posts: 9,601
Joined: 23-May 05
From: Bethesda, MD USA


What about selecting the fiels and then going to Format - Size - To Fit? After, then make the Detail section smaller.
Go to the top of the page
 
vtd
post Sep 30 2008, 05:34 PM
Post#5


Retired Moderator
Posts: 19,667
Joined: 14-July 05



Are you saying that the Height of the Detail Section is only tall enough to fit the TextBoxes (in a row in the tabular Report) but when the Report is previewed on printed, there are "vertical" space between rows?
Go to the top of the page
 
WSplawn
post Sep 30 2008, 06:52 PM
Post#6



Posts: 1,913
Joined: 1-August 07
From: Sacramento California


Hi Van,
>Are you saying that the Height of the Detail Section is only tall enough to fit the TextBoxes (in a row in the >tabular Report) but when the Report is previewed on printed, there are "vertical" space between rows?
Yes! For example: Lets say I'm printing two rows:
1 MAE54567
2 MAE45477
When I print this out in Access the amount of space (white space) between row one and row two is greater than what you see above. Not a great deal greater, but just enough to make me wish the rows were closer together.
Sometimes you run out of report real estate and to have the rows print with less space between them is desirable. I would guess you could get them as close together as you want, even to the point of overlapping.
In a spreadsheet, for example, you can have almost no space between the rows, but so far, I have not found a way to get them to print as close as I'd like in Access. It may just be an Access thing, and if it is I'll learn to live with it, but I wanted to ask before accepting that fact, if it is a fact.
Go to the top of the page
 
vtd
post Sep 30 2008, 09:32 PM
Post#7


Retired Moderator
Posts: 19,667
Joined: 14-July 05



I haven't used Access 2007 a lot so I can't say about Access 2007 but in earlier version, in the DesignView of the Report, you can set the Top Property of each TextBox to 0, all of equal height and then drag to bottom of the Detail Section to "touch" the bottom of the TextBoxes.

If you can't resize the height of the Detail Section as above, you may have some other Control that prevents the reduction of the height of the Detail Section. One that is easy to miss is the horizontal Line.

Make sure the CanGrow Property of all TextBox is set to False / No.

If I do as above + using borders around the TextBoxes, the Report prints like an Excel spreadsheet with cells + borders ..., i.e. there is no gap between TextBoxes.

Use TextBox borders to see if your TextBoxes touch. If they do, you may want to reduce the height of the TextBoxes.
Go to the top of the page
 
JVanKirk
post Oct 1 2008, 06:39 AM
Post#8


UtterAccess VIP
Posts: 4,243
Joined: 4-March 04
From: Clarksville, TN


I was going to suggest what Van posted in his last one here...put borders on all your boxes to see if one of them is growing for some reason...I have had that happen in the past, where one control kept growing a bit(still have no clue why because I would have expected to see data in the second row as well then...but it did, I disabled all CanGrows and it worked great...
Go to the top of the page
 
spudsta
post Jan 20 2020, 03:38 AM
Post#9



Posts: 1
Joined: 27-August 19



What you want to do is set the border style to transparent. Then set the Gridline Style for top, bottom, left and right to 'Solid'. Now set the Gridline Color to Black. Also set the Gridline Width Top, Bottom, Left and Right to Hairline (or thicker if you want).

From what I understand, the grid puts a slight gap underneath an object (like textbox). I couldnt find a way of getting rid of the gap. So what you do is to use the grid as your border by hiding the border on the textboxes, and making the gridlines visible.
Go to the top of the page
 
theDBguy
post Jan 20 2020, 03:17 PM
Post#10


UA Moderator
Posts: 77,526
Joined: 19-June 07
From: SunnySandyEggo


Hi spudsta. Welcome to UtterAccess! welcome2UA.gif

Just FYI, this is a 12-year old thread.

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 


Custom Search


RSSSearch   Top   Lo-Fi    25th February 2020 - 03:59 AM