Printable Version of Topic

Click here to view this topic in its original format

UtterAccess Forums _ Access Data Projects - ADP _ Odbc Connection Problem? Message Is “system Could Not Find The Database On The Server”

Posted by: Doug Galayda Sep 22 2017, 01:42 PM

A user getting this message on the Application.
“System could not find the database on the server”
I just connected another to the same system two months ago and his works fine.

I did find a DSN file below on the same network directory
Which does point to the correct server and Database name

So is an .ADP connected to a SQL server 2008 database the same way as a .accdb would be?

And can I test positive for a good database connection is to go all the way
through the steps all the way up to do the “test database connection” button from that users machine? --That is my very next step.

Also, I could create a new .dsn file, which I can and will do if I have to, but the one that is there seems to be working fine for me and another user.

**the .DSN below does list the correct server and database name

DRIVER=SQL Server Native Client 10.0
APP=Microsoft Office 2010
Description=ODBC connection to SQL C12

UPDATE: Ok I tried to go through the steps and got
“ODBC—Call failed
ODBC Driver Manager Data sour nsame not found and no default driver specified.”
--so I am going to create a new .dsn file.

Facts on the user with the problem running the .adp:
1) left for another job, for a month and came back, then got a new computer that was reimaged.
2) has the Same icon target+ start in properties as me and another successful user.
3) has the Same runtime and db Engine installed.
4) I did a ping on the cmd line to database and the problem machine looks just like mine and a collegues.
5) I and another user can access the ADP application fine,
But he seems to be having a ODBC connection error,
When he attempts to go into a table (per the application’s table maintenance screen)
it kicks him completely out.
6) The only difference I see is he running windows 10 and all successful applications
Are running windows enterprise 7, but we do not think that I the problem.

Also I am getting ANOTHER ERROR below on a laptop that is similar to the users machines.
Since we are using office 365, I had to put 2010 runtime and a 2010 db engine
On their machines(and the laptop) to be able to run the .adps.

“The action cannot be completed because the Microsoft Visual Basic for Applications—CRSLink (break] form_frmInvProc (Code) application (Microsoft Visual Basic for Applications CRSLink (break] form_frmInvProc © is not responding. Choose switch to activate Microsoft Visual Basic for Applications -- CRSLink (break] form_frmInvProc and correct the Problem”
When I hit the debug button it highlights a select statement being assigned to a variable.


Posted by: cheekybuddha Sep 22 2017, 05:51 PM

You appear to be using Trusted Connection.

So does the user have permissions to access the SQL Server?



Posted by: GroverParkGeorge Sep 23 2017, 07:48 AM

What version of Access was used to create the ADP? Is it the same version for ALL of you? Are all of the SPs applied to all versions of Access on all machines.

Try creating a new DSN, for sure. That would actually be one of my first trouble-shooting steps, if only to eliminate it as a possible source of the problem.

Posted by: PhilS Sep 23 2017, 11:58 AM

So is an .ADP connected to a SQL server 2008 database the same way as a .accdb would be?

No, not at all. An ADP connects to SQL Server using ADO and OleDB technology while an AccDb (usually!) uses DAO and ODBC.

DSN-Files are for DAO/ODBC. ADO/OleDB uses UDL-Files for the same purpose.

“System could not find the database on the server”

This is not a standard error message. Maybe you can find the location in the code that causes this error and get the original ADO/OleDB error message. That should be helpful in diagnosing the cause of the issue.

Posted by: Jeff B. Sep 23 2017, 12:07 PM

Another possibility -- I've had some customers who have not been able to connect to a SQL-Server instance because the version of the SQL-Server 'helper' file was older.

Posted by: Doug Galayda Sep 25 2017, 03:12 PM

In reply to Jeff B:

Thanks for you suggestion, I will check on that,
everything you suggest helps me on the way to a solution,
I appreciate you help.

Posted by: Doug Galayda Sep 25 2017, 03:28 PM

In reply to PhilS:

When I re-created the .dsn file for the ADP, I had Never created one before that,
And all the same steps you go through looked the same as it would in making a ODBC for a regular .accdb. That is why I asked, thanks for that information.

The user that gets that message is on the Windows 10 machine.
Me and another user do not get that message at all. (Running Access 2010 runtime)
But a message that we are seeing that is really perplexing that the windows 10 user is NOT seeing is this POP UP below:

“This action cannot be completed because the Microsoft Visual Basic application is not responding. Choose “Switch To” to activate Microsoft Visual Basic and correct the problem

Switch To Retry Cancel

Posted by: Doug Galayda Sep 26 2017, 04:45 PM

It was made with Access 2007(per the .dsn file description)

I created a new .dsn but I think my newly linked tables had a globe in front of them—as opposed to the original .adp (I working with a copy of the production .adp) So how did the the developer create the .dsn?
on a .adp I do remember my friend that made it now retired, said that adp are directly linked the server. There are no linked tables, true? And I linked them
Selected them from the database list.

I did create a new .dsn file, that did not improve it.
but I do remember when I looked at the linked tables in the left navigation pane
then showed the Old Dsn's specifications.
--so it my new dsn was not in Effect.

Posted by: Doug Galayda Sep 26 2017, 04:49 PM

Update: Getting closer and understanding the process better:
I found out where the failure is:
It blows up when it tries to open a table into a recordset

Set Log = db.OpenRecordSet(“tblLog”)

The .adp is a menu and calls a frm within a separate .accdb
(called CRSLink.accdb/frmInvProc)

(tblLog’s purpose is to record what Directory+file were imported into
The database. The date, event, Import(directory path), TCPath, NPPath, and status.
**The tblLog is listed in and is available to BOTH the the .adp and the .accdb
And shows data in both the .adp and the .accdb
**I don’t understand what changed to make this fail.
**I tried a 2 year old backup copy of the .adp and it fails also!
-- So that tells me something outside the app changed?

The outside .accdb/frm is called by a button on the .adp

I am hunting for the code that shows Where the call is made to the
.acdb, so I can change a test copy of the .adp and call a test copy.

Thanks!—all advice welcomed and appreciated at this point!