X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
   Reply to this topicStart new topic
> Remove A2010 Activation Screen    
post Apr 13 2012, 07:06 PM

UtterAccess VIP
Posts: 2,903
Joined: 12-April 07
From: Edmonton, Alberta Canada

Does anyone know how to remove the Activation screen that shows up when you first run a runtime application?
talking about this screen:

The above appears ONLY one time, fresh install...
Albert D. Kallal (Access MVP)
Edmonton, Alberta Canada
Go to the top of the page
post Apr 13 2012, 07:26 PM

UtterAccess VIP
Posts: 1,933
Joined: 12-April 06
From: BC, Canada

I would imagine Office stores a flag in a registry setting somewhere so I suppose that if you could identify that setting, then maybe your setup package could be made to set the recommended setting automatically in the registry.
Not sure though -- I develop in-house applications and so far have never needed to create a setup package.
Go to the top of the page
post Apr 13 2012, 07:44 PM

UtterAccess VIP
Posts: 2,903
Joined: 12-April 07
From: Edmonton, Alberta Canada

The general approach I use is to remove the display of the Eula, and in fact I also remove the finish and ok prompts. IN fact, my runtime install will just "start".
Owrap the runtime install in a Inno script, but that not relevant here).
I might as well share the steps to "remove" the prompts, nags, the Eula.
It is rather easy, and the steps are part of my question anyway:
If you extract the runtime like this:
AccessRuntime.exe /extract:c:\a2010rt
So, the above will expand out the whole runtime install to a dir (in this example c:\a2010rt)
You then simply in this root dir add xml file called
<Configuration Product="AccessRT">
        <Display Level="basic" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" /> //same as msp config
           <COMPANYNAME Value="CompanyName" />//same as msp config
           <Setting Id="AUTO_ACTIVATE" Value="1"/>
         <Setting Id="SETUP_REBOOT" Value="Never" /> //same as msp config

That is it.
The above results in a silent install. In fact you can display ZERO everything including hiding the progress bar by changing in above the
Display Level="basic" can be changed to "none".
However, I actually like the progress bar.
So with the above, a simple execute of the setup.exe in above dir will starts the runtime install, it finishes. And does so WITHOUT ANY nag prompts or the user having to hit next.
I also set macro security low so no nag prompts occur when you launch any file.
I don't even thus has to setup trusted locations. I use this :
Root: HKCU    ;
Subkey: "Software\Microsoft\Office\14.0\Access\Security"; ValueType:
dword; ValueName: "VBAWarnings"; ValueData: "1"

However, one might want to add some trusted locations, but with above you don't need to.
Anyway, all of the above works, all of the above is not the issue.
The issue is that Office needs to be ACTIVATED ONCE and this is even the case with the run time.
According to the office install documentation, if you want to do a silent install and you are utilizing volume licensing, then you can force a activation to remove this screen.
The documentation says this this should work:
           <Setting Id="AUTO_ACTIVATE" Value="1"/>

Note that I HAVE the above in the above config file.
In fact, I have no doubt it works. However in theory, the access runtime is an install of office, and it ALSO needs to activate the one time, but it NOT a volume license.
This might be a registry edit. I will post back here. I am also open to the idea that this is not a simple registry edit problem, but I simply don't know and hoping somone where does!
Albert D. Kallal (Access MVP)
Edmonton, Alberta Canada
Go to the top of the page
post Aug 4 2012, 04:32 PM

Posts: 1
Joined: 4-August 12

Try importing this registry information (remember to leave a blank footer line in the .reg file if you choose to deploy it that way):
Windows Registry Editor Version 5.00
Hope this helps.
Go to the top of the page
post Feb 18 2019, 07:41 PM

Posts: 7
Joined: 2-January 19

I'm chasing down how to remove the Office activation screen.

reg add "HKLM\Software\Policies\Microsoft\Office\14.0\Common\General" /v ShownFirstRunOptin /t REG_DWORD /d 1 /f

does NOT work for me. I tried testing this in a Windows 7 virtual machine (vm) and a Windows 10 vm.

I also tried adding the "FirstRunTime"=dword:0155cde9 as an additional key to the same path as well and it still prompts.
This post has been edited by AZDev7: Feb 18 2019, 07:51 PM
Go to the top of the page
post Mar 27 2019, 09:12 AM

Posts: 26
Joined: 1-May 18

I know this is an old post but: ---

Like Albert I use Inno to compile the installation of my apps - however this is executed from within a VB.NET installer which gives you the option of “elevating” the user privileges providing they are an “administrator” on that machine. This actually means that they are a “power user” in both Win 7 and 10 as the real administrators account is out-of-bounds for most normal users.

It also makes a difference as to where the runtime package location was, for instance a CD has the highest and the download folder on your PC one of the lowest. Also if the file you’re running is called “Setup.exe” (as in the runtime installation) Windows will “Shim” it for backwards compatibility issues and other peculiarities.

If you run the runtime installation as a process in VB.NET with elevated privileges installed in the .NET environment (the runtime that is) run from a previously marked safe location (Inno will do this for you when is does the basic installation) then I can confirm that if your project has set Macro security to low, then you won’t ever see a message as outlined by Albert.

This however all depends on any Anti-Virus software installed and the current state of the WMI configuration not to mention all the variables concerning which version of Office is already installed or indeed none at all. Also after the runtime has been installed a Windows update must take place before your app attempts to start, especially if no version of office exists on the installation machine.

Attempting to run your app without a Windows update will lead to great pain and misery.

In days of yore there used to be a DLL that you could install that would suppress such messages as Albert mentioned, but in recent years I think it’s been banished to the dustbin of time and I can’t remember its name anyway.
Go to the top of the page

Custom Search

RSSSearch   Top   Lo-Fi    11th December 2019 - 07:57 PM