UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Can't Set File Association    
 
   
stevew295
post Mar 26 2012, 09:03 AM
Post#1



Posts: 79
Joined: 3-May 10



Have two computers where I installed Access 2010 runtime on each. The first, which was a clean install of windows, office home & business 2010 (without Access). That install went just fine, no problems. On the second comuter, it did have Office 2003 Pro (with Access) installed. I uninstalled it first, rebooted, and installed the Office home & business 2010 and then after rebooting, getting updates, installed Access 2010 runtime on it. It works, with one exception. I cannot get the file association to work. On the first computer, no problem, double click on an .mdb and it opens it. On the second computer, even selecting "open with" and navigating to the proper msaccess.exe, it will not open it. Tries to open it in Adobe Reader. Un-installed the runtime, and just for the heck of it, un-installed adobe also. Rebooted, installed runtime again, same thing. Only this time after "open with" and selecting Access, it set the file assoction to windows media center. Just out of curiousity, re-installed Adobe reader and it set itself back automatically to Adobe reader (?).
can open .mdb's by using: "C:\Program Files (x86)\Microsoft Office\Office14\MSACCESS.EXE" Path\whatever.mdb in a shortcut, but I have to make a shortcut to every single .mdb! I've never seen where by going into "open with" and selecting any .exe to open a file, it wouldn't at least try to open the file (might not be able to because wrong format, etc) but it would at least bring up the .exe/program and then try to load the file.
Everything else on the second computer seems to work ok; Word, Excel, Outlook, and all non-microsoft programs. (btw, just barely went to Office 2010, so all databases are still in .mdb format)
Anyone else run into this? I suspect it has something to do with the fact that the second computer had office 2003 pro installed prior?
Thanks, Steve
Go to the top of the page
 
arnelgp
post Mar 26 2012, 09:36 AM
Post#2



Posts: 1,528
Joined: 2-April 09
From: somewhere out there...


have not experienced yet, but there are Freeware program out there like Type that can set file association manually.
Go to the top of the page
 
Squire4Hire
post Mar 26 2012, 09:38 AM
Post#3



Posts: 921
Joined: 1-October 10
From: North of the 49th Parallel


Good morning Steve,
Have you attempted setting your file associations through the windows control panel? It might be worth a shot instead of trying to default the 'open as'.
If you're running Windows 7, go to your windows Control Panel > Default Programs > Set Associations.
If you're running Windows XP, go to My Computer > Tools > Folder Options > File Types.
Confirm that all your mdb and acc file formats are set to be opened with the proper version of Microsoft Access.
It's a place to start anyway. Shy of that, I'm thinking you might want/need to check your registry settings.
Go to the top of the page
 
Peter46
post Mar 26 2012, 09:40 AM
Post#4


UtterAccess VIP
Posts: 7,489
Joined: 3-October 05
From: Oadby Leics, UK


Check the file association in control panel is correct.
ontrolPanel>Programs>DefaultPrograms>Associate a File Type....
Go to the top of the page
 
stevew295
post Mar 26 2012, 10:10 AM
Post#5



Posts: 79
Joined: 3-May 10



I tried using control panel, which still brings up the same "select program" dialog. No matter how many times I browse to proper msaccess.exe and select it, when I return, I still only have the options of Adobe Reader or Windows media center to proceed with. I included this screen shot, as it shows that other access extensions such .mda, .mde, etc show the proper icon for Access?????? I think that the access 2007/2010 file extensions also showed the proper icon as I was scrolling down. It seems that only the .mdb is affected??
guess the next step is to search for registry setting on first computer (the one that works), and see if I can find a key for .mdb, unless anyone has any other ideas?
The person whose computer this is just came along and kicked me off, so I'll have to wait for end of the day to experiment further.
Thanks to all who responded, Steve
Attached File(s)
Attached File  ScreenShot.jpg ( 243.09K )Number of downloads: 13
 
Go to the top of the page
 
HiTechCoach
post Mar 26 2012, 01:15 PM
Post#6


UtterAccess VIP
Posts: 19,037
Joined: 29-September 03
From: Oklahoma City, Oklahoma


If you have not do so yet, trying running the Repair option in the control panel under Add/Remove programs.
Go to the top of the page
 
stevew295
post Mar 26 2012, 05:18 PM
Post#7



Posts: 79
Joined: 3-May 10



It will be tomorrow before I can, but yes, I'll give that a try.
Thanks, Steve
Go to the top of the page
 
stevew295
post Mar 28 2012, 11:30 AM
Post#8



Posts: 79
Joined: 3-May 10



Tried running Repair option, that didn't help.
ound something I'll try:
http://answers.microsoft.com/en-us/windows...35-d98dbe96e327
which basically says:
The program that you're pointing to isn't registered correctly.
In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name.
Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit okay and then try and reassociate the file type as you normally would.
I'll try this when I'm able (when someone's not using the computer) and report back, but will be a few days.
Thanks, Steve
Go to the top of the page
 
HiTechCoach
post Mar 28 2012, 10:18 PM
Post#9


UtterAccess VIP
Posts: 19,037
Joined: 29-September 03
From: Oklahoma City, Oklahoma


Steve,
Thanks for the update.
Looking forward to hearing how it goes.
Go to the top of the page
 
stevew295
post Apr 17 2012, 12:21 PM
Post#10



Posts: 79
Joined: 3-May 10



Ok, finally got this soved, after being away from the office for a while. This is really a windows problem, I guess, but in case anyone's interested, here are the details.
exported about 25 keys (.mdb related) from computer that didn't have a problem. I imported them on problem computer, except for the user specific keys, and except for one key that wouldn't import.
Turns out, the one key that wouldn't import was the problem, because just to make sure it was the problem, I restored registry from backup and then only changed this one key:
Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.mdb]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.mdb\OpenWithList]
"a"="MSACCESS.EXE"
"MRUList"="a"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.mdb\OpenWithProgids]
"Access.MDBFile"=hex(0):
In addition to the "a"=MSACCESS.EXE", the problem computer also had
"b"="AcroRd32.exe"
"c"="OIS.EXE"
and the "openWithProgids" had something slightly different, I believe, but don't remember for sure.
Otried simply deleting the "b" and "c" values, but it wouldn't let me delte them, so deleted the entire key and then was able to import the reg file from the good computer with no problem.
after rebooting, icon in windows exporer still had the OIS.EXE icon, but upon choosing "open with", then, lo and behold, there was the access icon. Choose it, and works fine now.
She later had the same problem with excel, after opening an outlook message that had an excel file attached (.xslx). Instead of double clicking to open the attachment, she choose, "view as a picture" which immediately messup up the excel association and set it to something else. Didn't change the old file extensions (.xls), just the .xslx. Same problem of not being able to choose "open with" and reset file association. This time however, I immediatley went to same key (for .xslx) and changed it back.
So, not I know how to change these back, question is why they become "locked" in the first place.
Steve
Go to the top of the page
 
cooperk937
post Nov 7 2019, 04:30 AM
Post#11



Posts: 1
Joined: 7-November 19



Hi Steve,

Everyone may hate me for reopening a 7 year old thread, but I have to show my appreciation.
I was stuck on this for about 48 hours straight, it was starting to really hurt my head...

I had 3 new PCs brand new fresh out of the box, and 1 of them had this problem! Replacing the registry keys from one of the other PCs cracked it!

Thanks again
Go to the top of the page
 


Custom Search


RSSSearch   Top   Lo-Fi    27th May 2020 - 11:37 AM