UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Modifying A Label On A Form Ribbon, Access 2016    
 
   
Nak
post Mar 4 2019, 02:45 PM
Post#1



Posts: 53
Joined: 10-January 11



iconfused.gif Hi everybody
I have a form ribbon set in USysRibbons handling, among others, an independent label and a checkbox. How can I modify the label of the checkbox or the independent label? The getLabel sub doesn't seem to work with Access 16.
Thanks
Nak
This post has been edited by Nak: Mar 4 2019, 02:46 PM
Go to the top of the page
 
theDBguy
post Mar 4 2019, 02:52 PM
Post#2


Access Wiki and Forums Moderator
Posts: 74,985
Joined: 19-June 07
From: SunnySandyEggo


Hi. When you say the getLabel callback does not work with 2016, does it work with other versions? Otherwise, it should work.

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
Nak
post Mar 4 2019, 03:03 PM
Post#3



Posts: 53
Joined: 10-January 11



Hi DBGuy
When I add a getLabel="getLabel" in the RibbonXML field of the USysRibbons, the form ribbon doesn't display anymore
Thanks
Go to the top of the page
 
theDBguy
post Mar 4 2019, 03:07 PM
Post#4


Access Wiki and Forums Moderator
Posts: 74,985
Joined: 19-June 07
From: SunnySandyEggo


And what does your code look like for the callback?

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
Nak
post Mar 4 2019, 03:13 PM
Post#5



Posts: 53
Joined: 10-January 11



I attach 2 screenshots: the XML code and the callback sub
Attached File(s)
Attached File  Capture.PNG ( 19.27K )Number of downloads: 4
Attached File  Capture2.PNG ( 10.01K )Number of downloads: 4
 
Go to the top of the page
 
theDBguy
post Mar 4 2019, 04:35 PM
Post#6


Access Wiki and Forums Moderator
Posts: 74,985
Joined: 19-June 07
From: SunnySandyEggo


Hi. Try downloading this demo and select the LabelControl Ribbon to see if it works for you or not.

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
pere_de_chipstic...
post Mar 5 2019, 04:49 AM
Post#7


UtterAccess Editor
Posts: 10,411
Joined: 8-November 07
From: South coast, England


PMFJI

You have both "Label= " & "getLabel= " in the Ribbon XML for the control lbl_12:
CODE
<labelControl id="lbl_12" label="Label 12" getVisible="GetVisible" getlabel="GetLabel" ... ><


Try removing the label="label 12" statement.

hth

--------------------
Warm regards
Bernie
Go to the top of the page
 
Nak
post Mar 5 2019, 08:36 AM
Post#8



Posts: 53
Joined: 10-January 11



thumbup.gif
I owe more than 2 cents!
The download works correctly. I tried to modify it with IDBE ribbon 2016 ---> ribbon stopped working correctly.
I did the same with my DB ribbon ---> ribbon stopped working correctly.
Hence, I am making the changes manually in USYSRibbons
Many thanks
Nak
PS. It seems that IDBE 2016 doesn't manage the getLabel callback. I attach a screenshot
Attached File(s)
Attached File  CallBack.PNG ( 15.8K )Number of downloads: 3
 
Go to the top of the page
 
theDBguy
post Mar 5 2019, 10:01 AM
Post#9


Access Wiki and Forums Moderator
Posts: 74,985
Joined: 19-June 07
From: SunnySandyEggo


Hi. Glad to hear you got it sorted out. Just curious, what did your XML end up looking?

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
Nak
post Mar 6 2019, 03:51 AM
Post#10



Posts: 53
Joined: 10-January 11



Hi. I was making some additional tests. Some XML callbacks are not manageable by IDBE Ribbons: sizeString, getLabel. They have to be added manually. And it works now.
Anyway, I attach 2 files:
1- the XML file
2- A screen shot of the ribbon (it's a form ribbon)
Thanks for the help
Nak
Attached File(s)
Attached File  Ribbon.PNG ( 10.69K )Number of downloads: 6
Attached File  Test_XML.txt ( 5.75K )Number of downloads: 14
 
Go to the top of the page
 
theDBguy
post Mar 6 2019, 12:08 PM
Post#11


Access Wiki and Forums Moderator
Posts: 74,985
Joined: 19-June 07
From: SunnySandyEggo


Hi. Thanks for the update. Good luck with your project.

--------------------
Just my 2 cents... "And if I claim to be a wise man, it surely means that I don't know" - Kansas
Access Website | Access Blog | Email
Go to the top of the page
 
Dan Dungan
post Mar 6 2019, 01:35 PM
Post#12



Posts: 312
Joined: 20-July 10
From: chatsworth, ca


Clicking on the link opens another browser window. No text file gets downloaded.

--------------------
Dan
Go to the top of the page
 
Nak
post Mar 7 2019, 05:43 AM
Post#13



Posts: 53
Joined: 10-January 11



File sent by message
Go to the top of the page
 


Custom Search


RSSSearch   Top   Lo-Fi    23rd April 2019 - 01:19 AM