UtterAccess.com
X   Site Message
(Message will auto close in 2 seconds)

Welcome to UtterAccess! Please ( Login   or   Register )

Custom Search
 
   Reply to this topicStart new topic
> Iif Function, Access 2010    
 
   
rzw0wr
post Feb 12 2020, 11:04 PM
Post#1



Posts: 362
Joined: 28-March 12
From: Indiana


Problem Solved.


I am trying to figure out why this Iif function will n[size="5"][/size]ot work.

CODE
IIf([Charge]=0,"Not Charged","Charged")



My query

Attached File  Annotation_2020_02_12_230233.png ( 19.92K )Number of downloads: 12



Thank you,
Dale
This post has been edited by rzw0wr: Feb 12 2020, 11:34 PM

--------------------
Access 2010 32 bit.
Not really very good at access.
Go to the top of the page
 
MadPiet
post Feb 12 2020, 11:29 PM
Post#2



Posts: 3,466
Joined: 27-February 09



Click the SQL button, and copy and paste that. not a picture. Sorry, but we can't read a picture.

-Grumpy Old Man
Go to the top of the page
 
rzw0wr
post Feb 12 2020, 11:33 PM
Post#3



Posts: 362
Joined: 28-March 12
From: Indiana


I found out what the problem was.

Sorry for the picture, never thought about SQL.

Thanks,
Dale

--------------------
Access 2010 32 bit.
Not really very good at access.
Go to the top of the page
 
BentBrain
post Feb 12 2020, 11:34 PM
Post#4



Posts: 520
Joined: 10-February 03
From: Thailand


Hi rzw0wr

Try changing the field in your query to this.

field = NotCharged:IIf([Charge]=0,"Not Charged","Charged")

don't put it in criteria.

Let me know if that helped.

Regards
BentBrain

--------------------
"There is no excellent beauty that hath not some strangeness in the proportion" Francis Bacon
Go to the top of the page
 
rzw0wr
post Feb 13 2020, 08:32 PM
Post#5



Posts: 362
Joined: 28-March 12
From: Indiana


Thanks BB.

Thar is what I did.

Thanks for the replies,
Dale

--------------------
Access 2010 32 bit.
Not really very good at access.
Go to the top of the page
 


Custom Search


RSSSearch   Top   Lo-Fi    19th February 2020 - 01:29 AM